My two-year old Dell Dimension 2400 died three days ago in the middle of computing -- The notorious blue screen appeared and saying physical memory is dumped. When I tried to reboot, it says 'primary hard drive disk 0 not found'.
In BIOS it says 'hard drive (device unknow)'. I did not do any thing to the hardware recently. It seems quite a lot of people experienced similar problem , but I just could not find a good solution (or maybe I should have spent days garner the information from the internet).


Recommended Answers

All 11 Replies

Check for a loose hard drive interface or power cable first. Check the interface cable at the motherboard as well. When you power up the computer can you hear the hard drive spinning? If not you may have a faulty hard drive or a bad power supply, both of which could have caused the BSOD. Is all the other information in your BIOS correct? If not, you may need to replace the CMOS battery.

Thank you for the reply. My friend tested the hard drive on his computer and computer could not read it or found the disk. It is only a two-year old Maxtor hard drive on a Dell. I finally replaced the hard drive over the Labor day weekend. Fortunately I didn't store important data on the disk; my computer is mostly used as a terminator connecting to my school.

check ur bios for an autodetect hd.....either as a stand alone feature or on the main cmos page. You could set for auto.

Nothing to do with RAM.

The link you were given describes what you've already done!

When you've done what bugzz said (which you have), then the usual cause is a glitch that caused the HDD to write in the wrong place (like the header information).

Either this is a bad drive (unlikely) or a power spike coming from the mains or your PSU.

Anyway, it's rendered your HDD unuseable. It should be detected by a low level utility like FDISK. But that seems to be academic now as you've posted your solution. Perhaps you could mark this thread as solved.

uhh.. okay.. I learned a thing from you.. (^.^)..

To Sushipo...why be a jerk...As far as I'm concerned - nobody DID FIND OUT What was wrong with his hard drive...A LOT OF US WOULD like to know how to fix WITHOUT REPLACING the current hard drive.

no in the hard drive my importent data i m save his data so plz help me

I have similar problem. I have an old Dell 4500 from my daughter that won't boot. Says "F1 to xxxx, F2 to yyyy". I removed her HD and slaved it into my professionally built PC. I copied her data onto flash drive and then removed my HD and made hers the master. Had a few glitches, mostly needing to update XP and HP/Dell software. Worked well after that. Got her HD IDE cable and jumper strapping info from mfr site. Removed her HD from my PC and put it back into the Dell per above instructions. No joy, Same F1, F2 results. Got into BIOS and set it to Auto-detect. Unable to change RAM number. Rebooted but again, no joy. Pls help.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.