I know ive seen similar posts on here, but none of them seem to apply. I just assembled this computer with the help of my friend, who knows what he's doing with computers. After we put everything together, pushed the power button, nothing. he checked the connections, changed the power cords, and we got it to work once, boot up fine, installed windows, smooth sailing. I took it home and just tried booting it up again, same problem. literally nothing happens when i hit the power supply. I double checked all the connections to make sure they were tight. The green LED light on the MOBO IS lit when its plugged in. i tried unplugging ram, plugging it back in, different power cords, different outlets.. i know its configured properly because it was just running yesterday, but now nothing works. any ideas?

Re: Computer Doesn't power on at all 80 80

Could be a short somewhere in your box, probably the MB. Try removing your whole MB then putting it back in again.

Re: Computer Doesn't power on at all 80 80

Why did you unplug the ram in the first place?

Re: Computer Doesn't power on at all 80 80

i dont know what to do

Re: Computer Doesn't power on at all 80 80

i dont know what to do

take a long walk ,come home read a book ,then throw the computer out the window .hehe

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.18 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.