spiker2010 0 Newbie Poster

I bought a new motherboard (asrock n86c-s ucc) because my old one's PCI-E slot was not working. I installed the board properly the first time with my cpu and everything seated correctly in a new case only to find that my computer was not turning on at all woth 2 different motherboards including the new one. I fixed this problem and successfully booted the new motherboard straight into windows. After turning off my computer to install my new internal SATA HDD, my computer would not POST. The PSU's fans, CPU's fan and Graphic card's fan all powered on but my monitor just stayed in standby mode. I unplugged and re-plugged the monitor's VGA only to realize it said immediately "Entering Power Save". I switched the monitor with my second computer's monitor, still to get no POST. I tried another PSU from an old computer, still no POST. I bought a new PSU (ATX 800 Watt - Omega), still no POST. I transferred everything to my previous motherboard that was working before, I get no POST. Previously during transferring the components back and forward to 2 different motherboards including the new one, I had to force the CPU out of one of the motherboards (AMD Athlon X4 Core), it was chipped at the top left corner. I placed my hand on the CPU (with the fan off) while the computer was on, on the CPU, and it heated up as it was suppose to, that takes a dead CPU out of the question. I can hear a beep when I remove my RAM from the motherboard (previous), unfortunately the new one does not have a speaker. Three motherboards, three PSU's, 2 RAM sticks and no success in POST'ing. I have hit a brick wall, PLEASE HELP ME

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.21 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.