I have an iOmega Home storage 1Tb model 31803000, which contains some info I would like to recover.
Had it working on XP using a router (Sitecom 300N), but it stopped working normally, went visible/invisilbe and when visible stopped during data transfer.
Now I am on Windows7/x64 Home, but still have an XP on a netbook. Still not usable.
When I ping the drive on 192.168.0.109 it responds correctly.
The iOmega Store Manager application can find the system but shows only one [of a dozen] folder saying ?:GT<
Browsing on that, using the Store manager application doesnt bring me into the iOmega NAS, but into shared area in W7 PC.
Firefox nor IE can connect to 192.168.0.109.
Question: how do I get into this drive and try to recover some of the files I did not have in backup?.

How confident do you feel about downloading Ubuntu and burning it onto a disc?

Ubuntu, ran as a live disc, (which means you won't have to install it, just boot from it) should be able to read any salvageable data on that drive. But this means that to achieve this you will need to take the Hard Drive out of the Enclosure and connect it directly to your computer. You can put the drive in a cheap external USB enclosure, or, if your iOmega unit can connect via USB that may be just as good - however, using a different enclosure would negate any issues the controller in the iOmega may have. (we don't know the cause of this loss of access yet)

Connect the Hard Drive to your computer while it is off. Boot into the Uburtu live disc and then look for the attached drive. What do you see? If you don't see your files then we'll need to follow some further steps.

[If you need any help with anything I've said, please say and I'll explain it better]

Have Ubuntu running on another system. Tried to connect the system directy [without the router] with a crossover cable. Same result. Could ping, but no other access possible [so far] Hesitate to take the drive out of its enclosure..[never done before].

Does the manual describe the process of resetting the iOmega storage unit?

Considering your uncertainty, (which is understandable - 1TB is a let of data) you may benefit from getting some hands-on help in making any further steps.

Tried the reset already. No luck.. Thx for trying to help BigPaw.

Don't give up just yet. I'm going to dig out the manual for this.

Can you tell me if this is definitely the manual for your iOmega drive, please? I'm going to spend a little time reading through it, and perhaps others would like to do so also?

If this is the correct manual for your drive, can you access this menu depicted at the bottom of this page? (There are instructions on that page explaining how to reach that menu.)

BigPaw, I recognise the system, manual looks indeed the right one. Thx for the effort, anything I can do?

At the bottom of this page it refers to a disk you will have received with your iOmega unit. It seems that on that disk is software which way repair your drive. Do you still have the disk?

Also, are you able to access theConfiguration Menu?

BigPaw, Re-installed the disc and have taken screenshots of results in Dropbox
As I don't know whether links are permitted here..so I will describe it..
It starts with https double slash forward dl dot dropbox dot com slash forward
u/2675530/iOmega.zip . Hope it gives you a clou of what is the case... Thx.

Yes, you can drop links in here. I've tried your "link" above and it didn't take me anywhere, sorry. :)

(When I say you can post links in here, I'm just pointing out what I've seen done previously. I'm no authority here)

Picture 5 indicating how the drive is seen in explorer; (i) that network drive is showing that about a quarter of it has been used, does that look about right from what you remember, or is there a lot missing? (ii) What happens when you click on that drive?

What iOmega software do you currently have installed?

I started a new appraoch.. A friendly neighbour helped me to dismantle the disk. Now I have the disk directly connected to Ubuntu. Ubuntu recognise the system, but reports "invalid partition structure", so now I hope to recover the files although the partition is a little bit problematic. Looking and browsing for solutions..

That's really good, that's what I suggested at the outset, well done. Hope that doesn't sound patronising, it's just that I know how you felt about doing this at first.

In Ubuntu download a program called Testdisk. The next thing, because this is now a Linux problem, is to now visit the Linux forum here. Give them a rounded explanation of your situation including this info:

(i) Make & model of your network drive. (ii) How you have the hard disk attached to your computer now. (iii) The invalid partition error report. (iv) The version of Ubuntu you are using, and that you have Testdisk installed.