0

Hello everyone!

Another serial mouse question! (I did not want to revive my 1 year old dead thread for this)

I'd love to use my 1988 Logitech ClearCase serial mouse with... well with any Windows OS other than Windows 3.1 (It seems to work fine). This mouse is actually a Logitech C7 serial mouse, it's just a fancy clear case they put on it and when booting into and running pure-dos (Ms DOS 9.10 apparently) I load the program ctmouse (Version 1.9.1). I load this program high (lh ctmouse) and it installes this mouse in "mouse systems mode"-- that's all it does the mouse doesn't work in dos, but it work flawlessly in Windows 3.1 using the Logitech driver that came with 3.1. When I run comtest (comes with ctmouse Version 2.1) on my laptop, the mouse is a "modem" it says however i disconnected the mouse and left the serial cable for it plugged in and comtest still said it was a modem! but the mouse was not attached!!!

So, I'd like to see if I can prevent Windows XP from loading any mouse drivers and get it to load ctmouse instead, and maybe then I can see if the mouse will work...

(Sorry for the long post! I wanted to give every detail i have)

Javanoob101

3
Contributors
7
Replies
27
Views
5 Years
Discussion Span
Last Post by javanoob101
0

Have you just tried to plug in mouse when system is powered down, and then booting it? It should recognize it and install the appropriate drivers; however, since just about no current mice use serial rs-232 interfaces, this may not work... :-( Time to get a USB mouse perhaps?

0

this means wndows is only seeing the serial cable ,and not the mouse ,what happens when you plug the mouse directly into the Serial port with out the cable

mouse is a "modem" it says however i disconnected the mouse and left the serial cable for it plugged in and comtest still said it was a modem! but the mouse was not attached!!!

0

Sorry caperjack, that's not an option...(How? it needs the cable to work)

anyway, after 3 years of trying to get the mouse to work under windows... I have some success!
I finnaly got the mouse to run under Windows 98! I ran ms-dos prompt from the start menu, then i browsed to ctmouse.exe (Version 1.9.1) and it installed the mouse in mouse systems mode. I closed the ms-dos windows an the mouse was still lit up! (I soldered in an red LED to show that it has power and it it working) then I ran the "Install new hardware wizard" in 98 and it found and installed "Logitech Mouse" great, ok it restarted and like usual, the mouse "was disconnected" so I right clicked on the mouse and clicked on "update driver". Snooping through the Windows 98 CD I found a folder with... Mouse Systems Drivers!! =) So i forced windows to install the "Wrong drivers" (It said they are not meant for my mouse) restarted and ta-da! The mouse works flawlessly in windows 98 now!!!

My problem is this: the .inf file seems to be made for Windows 3.1 as it installs the Windows 3.1 drivers (that's what the inf says). I tried to install then (right clicking on the inf and clicking on "install") in Windows XP to no success... I even copied the drivers and inf to the system32/drivers folder and even the windows/inf folder but nothing happens... I modified the Win.ini and system.ini files with the same entries as the windows 98 computer but no luck...

How can I install Windows 3.1 (.386 drivers) on a Windows XP machine? -- Is it possible? (There must be a way!!)

Thank-you SO much for reading my seemingly endless posts... =)

Javanoob101

0

Oops! Sorry Rubberman, I missed your post...

Yes I tried plugging it in while the system is off, but no luck...
USB mouse you say? Yeah right! my laptop only has on as it is!!! =)
But no i use the built in touchpad right now, I still think that this retro '88 mouse would be killer to show my friends!

javanoob101

0

Alright, more news on the mouse.

It works in XP with one major exception: only in command probpt and only after i run ctmouse.exe. then if i run a dos program, say edit.exe (type in edit) the mouse works after I unplung and re plug in the mouse while edit is running! then it works. as soon as i close edit though, the mouse doesn not work. also, if i close cmd, i need to run ctmouse again to get the mouse to run...

What's up with that?

javanoob101

0

OKAY! (Sorry I feel like a noob for posting so much!)
I edited the boot.ini file with notepad and deleted the part that says "/fastdetect" /fastdetect disables the com ports during boot so windows will boot faster. trust me I see why, it took 2 minutes to boot because it was looking for serial devices.

So now i need to install the driver for the mouse...
I'll keep everyone posted!

javanoob101

EDIT: i said that my mouse has power, but i just had the /debug option on so it was sending data throught the com1 port sorry.

WARNING!!! BE SURE TO BACK UP YOUR BOOT.INI FILE BEFORE YOU MODIFY IT!! YOUR SYSTEM MY NOT BOOT AFTER IF YOU MESS UP!!!

Edited by javanoob101

0

Oh my gosh... I have the biggest headache from this mouse!
I'll make it simple: I made my laptop dualboot Windows Xp ans Windows 98. After 2 hours of installing drivers, setting up COM ports the mouse finally works!!

tips for XP users: delete the line in the boot.ini file that says: /fastdetect -- This switch disables all com ports at boot so XP doesn't waste time trying to detect serial mice and such. If your mouse is newer, delete that switch and maybe yur mouse will work!!

Thank-you caperjack and rubberman for actually reading my ridiculously long posts and for the help!!

Cheers!
Javanoob101

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.