0

The following happened when I tried to turn off the laptop from Windows XP prompt.

After an extended period that the screen indicated Windows was shutting down, the blue screen memory dump came on briefly. Then the screen blanked and the computer restarted instead of turning off.

While restarting, it went through the bios routine and then the screen blanked and stayed that way. The CPU fan was running at high speed, also. I tried turning the laptop off but it wouldn't switch off even when continuing to push the switch in. So, I had to disconnect the AC adapter and pop the battery out to turn it off.

I plugged it back in and tried to power back up. Nothing except the LED showing that it's plugged into power.

I took the laptop apart and found that two of the heatsink posts had separated from the motherboard. I had repaired these about two years ago the first time they had separated. So, I repaired them again.

Still nothing, using AC or battery. I've also tried pulling out the CMOS battery to try to reset the BIOS.

Any ideas? Is it likely that the CPU is dead?

Thanks,
Denis

2
Contributors
2
Replies
3
Views
11 Years
Discussion Span
Last Post by pktboy
0

Symptom update - When I plug in the adapter cord (battery not installed) while holding the power switch down, the power and battery charge lights on the front panel momentarily blink on and then back off. No other signs of power. Is there thermal protection circuitry that somehow needs to be reset (BIOS?) before any other power can come back on and maybe not a problem with the CPU itself?

Thanks,
Denis

0

I wonder is the Compaq Presario 2720US a laptop or a desktop? I'm having a problem with a Presario laptop and wanted to know how I can reset CMOS? A BIOS flash went horribly, horribly wrong.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.