0

Hi
I have a fairly old Time Cybernote 953E laptop, which I beleive is a rebranded CTX EzBook 700E. I'm trying to replace the hard disk from the tiny 3 gigs it had to 80 gigs. However the laptop is having trouble detecting it.
When I go into the BIOS is says
hard drive C = 0 MB
# Cylinders = 1023
# Heads = 0
Sectors/Track =63

I tried running fdisk and this did find the HDD, but only as 8 GB not 80.

I've tried the hard drive in another even older laptop (acer - not sure of model) and it works fine. I've also connected it in an external HD case via usb to my desktop and all seems fine.

Is it likely to be a fault with the Time laptop or a bios issue? I've looked at reflashing the bios, but CTX no longer make laptops and I cannot get hold of a new bios from their site.

Any suggestions?

3
Contributors
6
Replies
7
Views
10 Years
Discussion Span
Last Post by Turnip
0

As you may have already figured out the BIOS will not recognize a hdd that large in a system that old. You are probably looking at a limit of 10MB to 20MB. Try downloading SIW and see what the BIOS is and then google it to find out the max size it will detect.

By the way, system information for window is free and a great utility, try it...you'll like.

0

there's a program on the Internet not sure what it is though go to www.labrats.tv watch the show where they update the bios and there's a program where it finds a bios update automatically without booting of a floppy and all that. This should help you update you bios so you can get your hard drive working

Hope this helps:)

0

The problem there Bondi is that the machine is so old that there probably will not be a BIOS upgrade that is going to allow him to use a hdd that size.

0

With a computer of this age I doubt that you will find a BIOS update that is going to recognize anything larger than 10GB to 20GB, and that's the definitive point.

There may be another issue with a computer of this age, and that is whether the BIOS is on a EPROM or a EEPROM. The older computers used EPROMs which the BIOS was burned to , and that was it, the EEPROM can be rewritten.

0

Cheers for the advice, I'll google the bios when I get back from work. It's a bit infuriating really, I had a 40 GB disk tha was 6 months old that I put in it that worked at first then the same symptoms occurred. I sent it back under waranty and got a refund, which, because of the change in prices, meant I could get an 80 GB replacement. Oh well, I'll have to check the specs more carefully next time. At least I can use it as an external HD for my desktop.
Maybe I'll just have to stop being so tight and buy a new one instead of trying to revive a freebe :)

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.