0

Please help me. I need your help badly.
I already post my problem below as the reply to the similar case, but after a few days since no reply for me.

I want to use USB external casing with 40 GB Fujitsu notebook harddisk in it.

I tried several boot disks I made from
http://www.bootdisk.com , etc.
And all usb driver I could download
(DUSE 4.4 & 4.9, MOTTO HAIRU, etc..).

But still no luck.

One type of bootdisk I made was :

config.sys :
dos = high, umb
device=himem.sys
devicehigh=USBASPI1.SYS /v /w /e
devicehigh=DI1000DD.SYS
device=a:\duse.exe
files=100
buffers=60,0

autoexec.bat :
set clipper=f50


When I booted, then displayed :

……………….
……………….
Available ID = 0
ID 0 = HD .. FUJITSU MHV2040AH
#1 : PRI DOS (FAT32) 20975MB drive = C:
#2 : Logical 19034MB drive = D:

DUSE verson 4.4 Build 110 Release (General)
DOS USB Stack Diver with USB Storage Extensions
Copyright Cypress Semiconductor, 2000-2002

EHCI USB Controller initialized (BASE 0xd0000, IRQ 11)
UHCI USB Controller initialized (I/O 0x600, IRQ 10)
UHCI USB Controller initialized (I/O 0x640, IRQ 10)
UHCI USB Controller initialized (I/O 0x680, IRQ 5)

USB CD-ROM support enabled
CD-ROM : <not installed>

USB Drive support enabled
Drive E : <not installed>

- kursor blinking

Then nothing happened when I press any key on keyboard.
It hanged there.
No drive " A:/> " displayed

What’s wrong ?
I’ll really appreciate your help.

Best regards,
Meiti

3
Contributors
3
Replies
4
Views
11 Years
Discussion Span
Last Post by sylvled
0

I'm just going to give it to you straight.

USB drives SUCK in DOS. No matter what driver you attempt to use with it, it's not going to work, or work that well. I attempted this last year using a number of different methods, and it still took over 2 hours to transfer a 1GB file onto my drive.

Bottom line is that you're not ever going to get acceptable performance with a USB hdd in DOS.

0

Thank you Alex.
Seems that you had successed accessing external USB harddisk from DOS.
Would you mind to tell me how you did it ?
I need to try it for a small program that less than 1MB.

I'll really appreciate your help :)

0

Hi,
Most probably your keyboard is usb too...
And when you use any driver, the keyboard that was drived by the bios is after drived by the driver. BUT ! Your computer is NOT hanged !
You can continue scripting in autoexec.bat.

You could use the /norst option on usbaspi.sys... It helps sometimes...
I did not have any succes by my side... Let me know if you have success...

Yours.
Sylvain.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.