0

Suddenly my ftp is not working on sub-ftp accounts but works on main.

specs:
cpanel/whm
fedora core 2


I switched between pro ftpd and pure ftpd several times back and forth (usually fixes the problem).

Steps:
/scripts/updatenow
/scripts/fixproftpddupes
/scripts/ftpup pure-ftpd
/scripts/ftpup proftpd

/etc/proftpd.conf seems to have only one of my domains but not all the rest. I don't know why.

the error I get when connecting to a sub account is:

Connect socket #780 to xx.x.x66.223, port 31231...
150 Accepted data connection
226-File successfully transferred
226 0.084 seconds (measured here), 104.08 Kbytes per second
MDTM 20041105180922 sslstarter.gif
550 Can't check for file existence
PASV
Transfer time: 00:00:01
227 Entering Passive Mode (xx,x,x66,223,90,220)
LIST -al
Connect socket #796 to xx.x.x66.223, port 23260...
150 Accepted data connection
226-ASCII
226-Options: -a -l
226 3 matches total
Resolving mydomain.com...
Connect socket #836 to xx.x.x74.2, port 21...
220 (vsFTPd 1.2.1)
USER myusername@mydomain.com
331 Please specify the password.
PASS **********
530 Login incorrect.

2
Contributors
1
Reply
2
Views
13 Years
Discussion Span
Last Post by kc0arf
0

HI,

I have returned to wu-ftpd as it appears most flexible to me. BUt I also firewall it off to the internet, so that no incoming internet connections can use FTP to reach me. For internet connections, I have SCP available.

Christian

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.