0

i have a laptop wireless card and i want to use it with linux. I am sure it is a setting as it detects everything correctly.
specs 650+ d-link wireless PCMCIA
suse 8.2

7
Contributors
8
Replies
9
Views
14 Years
Discussion Span
Last Post by deadleaves
0

It detects it ... so what's the problem? ;) Does it need to be configured to get an IP (for DHCP, for example) ??

0

not sure what the problem is, shows up on boot and everything. says it works but it does not connect. i have it set on DHCP, however i think it tries to use my onboard card first, might be problem. anyone install a wireless PCMCIA card in linux?

0

"specs 650+ d-link wireless PCMCIA"
The 650+ uses a newer Broadcom chipset than the older 650. Broadcom hasn't supported linux at all. There are some projects around to create some workable drivers. Look on the the
Seattle wireless site for a hardware comparison. Also, Linuxant has a driver wrapper available to let linux use the windows drivers. It's a 30 day free trial,then $20 and can be used on different installations. I use the linuxant package with a Linksys and a SWC wireles G cards- both get between 34-50 Mbs.

0

A friend of mine (mistakenly) bought the same card for his linux laptop and he told me that it used a Texas Instruments chipset and that it did not work. I later read and confirmed that the d link 650+ wireless card does use the TI ACX100 chipset for which their currently is little or no support.

The first card I tried to use with linux was an SMC 2435 which had a TI chipset and it did not work. TI will not release information on their chipset due to whatever reasons, and they obviously are not going to put out any linux drivers anytime soon. There is an ongoing project to help remedy this but that's an entirely different story and monster of it's own. Anyway, I tried the card on Suse and even though it detected the chipset, it could not get the card to work. Suse is great at detecting alot of hardware regardless of whether it's going to work or not.

Anyway, it's the 650 with the prism chipset that works, not the 650+. Unless you're up for the challenge (and headache), I would suggest finding a linux compatible card that works right off the bat.

The second card I got (on a tip that it worked with linux) was an SMC 2635W that I purchased from e-cost for like $16. It uses the admtek chipset and admtek did linux supply drivers; therefore it did work. I used it on red hat 9. However, I'm running gentoo on my laptop now (and loving it) and the admtek driver does not compile correctly. Therefore, I'm purchasing a dlink 650 (not the 650+) tomorrow.

Anyway, best of luck.

0

You will probably want to check out the Sourceforge site for the ACX100 drivers
http://acx100.sourceforge.net/

Looks like the 650+ has been varified to work with this driver

Steve- WTF are you doing here?? 1st me, then Alex, and now you. What? Have we left Dale to man the ship by himself? Good god man- he'll drink all the liquor!

:D :D

0

Just wanted to inject that I did purchase the dlink 650 (not the 650+) and there has been yet another revision in the chipset. (Rev M1)

It has a realtek chipset of some type, that without a lot of self punishment, will not work. If anyone has gotten it to work, please let me know. Otherwise, if you're planning to get a dlink 650 because the price is right, be sure to get one of the older ones that still has the prism based chipset.

I'm currently using my ambicom cf wireless card from my zaurus in my laptop to remedy my wireless needs, and it works great.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.