0

Hello
First i am very very new user in Linux redhat 9 kernal 2.4.20-8
i have intel ham v 92 fax data voice hardware modem (PCI),
chip no=MD5628D-L-B
which work find on XP but when i decompress and install its driver (412-2tar.gz) in LINUX REDHAT 9 kernal 2.4.20-8
Root]#/usr/local/src/ (here i have modem decompressed drivers)

i am unable to detect my PCI Hardware modem

WHAT I DO
----------
According to readme.txt file
3. INSTALLATION

Prerequisites:
1. root access
2. bash shell to run install scripts
3. a HaM modem
4. kernel source for the kernel you are running
/usr/src/linux must symbolically point to this source
for the makefiles to work.


6 steps to install
1. login as ROOT
2. extract the archive into a directory with "tar -xvf <archivename>.tgz"
3. cd into the the directory it created.
4. Type: make clean
5. Type: make all
6. Type: make install
I Take All these steps as a ROOT and copy all from terminal just for any expert that what i should be wrong while i am installing modem drivers


[root@localhost src]# cd 412-2
[root@localhost 412-2]# make clean
cd coredrv; make clean
make[1]: Entering directory `/usr/local/src/412-2/coredrv'
rm -f *.o *~ core
make[1]: Leaving directory `/usr/local/src/412-2/coredrv'
cd serialdrv; make clean
make[1]: Entering directory `/usr/local/src/412-2/serialdrv'
rm -f *.o *~ core
make[1]: Leaving directory `/usr/local/src/412-2/serialdrv'
rm -f ham.o
rm -f hamcore.o
[root@localhost 412-2]# make all
cd coredrv; make ham;
make[1]: Entering directory `/usr/local/src/412-2/coredrv'
cc -DLINUX -Wall -O -I /usr/src/linux/include -I../inc -c -o coredrv.o coredrv.c
make[1]: cc: Command not found
make[1]: *** [coredrv.o] Error 127
make[1]: Leaving directory `/usr/local/src/412-2/coredrv'
make: *** [ham] Error 2
[root@localhost 412-2]# make install
bash haminst
running kernel 2.4.20-8
installing hamregistry, used for persistant storage
installing hamregistry data
installing ham module
install: cannot stat `ham.o': No such file or directory
installing hamcore module
install: cannot stat `hamcore.o': No such file or directory
redhat hamboot rc2.d and rc3.d scripts
starting module and utilities
insmod: hamcore: no module by that name found
done
[root@localhost 412-2]#

please any expert in Linux tell me what to do
thanks
knight

3
Contributors
4
Replies
5
Views
12 Years
Discussion Span
Last Post by Thong_Ispector
0

make[1]: Entering directory `/usr/local/src/412-2/coredrv'
cc -DLINUX -Wall -O -I /usr/src/linux/include -I../inc -c -o coredrv.o coredrv.c
make[1]: cc: Command not found

The make command is looking for the "cc" compiler (in order to create the coredev.o file), but is apparently not finding it. That initial failure is the cause of the subsequent installation errors.

Chances are that you may not have the cc compiler installed, or that the gcc compiler is installed instead of cc. Use the following two commands to determine this:

which cc
which gcc

If the "which" command reports that neither compiler can be found, you'll have to install them; they should be available in the Development packages on your install CDs.

If which indicates that gcc is installed instead of cc, you need to make a cc symlink that points to gcc. Asumming that gcc lives in /usr/bin/ on your system, you would do:

ln -s /usr/bin/gcc /usr/bin/cc

Obviously, if gcc lives in a different directory on your machine, replace the /usr/bin/gcc path above with the path that's correct for you.

0

thanks DRM

At least i got a rite path thanks man again i try many forums and this is a lucky for me ;)
knight

0

Cool- glad we could help. :) Give us a shout if you run in to further problems.

Just FYI- a couple of us here also work at this Linux support site. We've got a lot of helpful, knowledgeable members there who would also be more than willing to help.

0

Do you have kernel source and kernel headers on your system?
I was having the same problems with Ham modems

I know the docs say that that is a hardware modem but HAM is not a true hardware modem. I tried 12 different modems that said linux all over the box and NONE of them worked right. Out of desperation I tried one that did not say Linux anywhere on the box, it did say requires WIndows 98 or XP...

It worked fine without any drivers or configuration...
It was the cheapest external modem on the shelf (Airlink) is the name I think...
The name is not even on the modem... I just checked...
It just says V92 Modem and RS232 no name, no model number...

I swear, the box did not say linux comp.
It did say requires Windows....

I even special ordered one modem... Intel 536ep that had linux all over the box and it did not work...

Hey, I just found the Airlink box...
It now contains half a dozen internal modems...
Airlink AME003

Save yourself some time and frustration....

FYI, this system also has Windows on it and I had a harder time getting it to work in Windows than I did three different versions of Linux...

Not that it was hard to get it to work in WIndows, but with Linux it just worked..
I didnt have to do anything...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.