0

I have an Asus Eee 900A with Ubuntu NBR 9.04 installed. When I installed the system, I made one partition on the internal SSD and mounted as /. I left 32 MB for swap space. I mounted the /home directory to a 16GB SD card installed in the memory card reader.

Although not exact, here is basically my /etc/fstab file:
/dev/sda1 / ext4 defaults 0 1
/dev/sdb1 /home ext4 defaults 0 0

But when I start up, I get the following error message:
Your home directory is listed as: '/home/tim' but it does not appears to exist. Do you want to log in with the /(root) directory as your home directory? It is unlikely anything will work unless you use a failsafe session.

If I log in with a fail safe session, and then edit my fstab file, or even just open it without a modification, and then restart the computer (without powering down) then it will work. But if I power the computer down, it goes back to the error message. When I am able to get the system started, I can see that the /home directory is in fact where it belongs and it's all there.

Attachments
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda1 during installation
/dev/sda1	 /               ext4    defaults	0       1
# /home was on /dev/sdb1 during installation
/dev/sdb1	 /home           ext4	 defaults	0       0
# swap was on /dev/sda5 during installation
UUID=4f0a9923-9c7f-40b6-8e82-460f8500455b none          swap    sw              0       0
1
Contributor
2
Replies
3
Views
8 Years
Discussion Span
Last Post by Dukane
0

I did find a solution to my problem in between posting and now as I continued my troubleshooting. In the memory card, under the root directory was the folder "tim". What I did was create a new folder "home" and then move "tim" under "home". This seems to have corrected the issue, the system now logs in with all of my settings each time. I suppose alternatively I could have also changed my HOME environment variable to point just to "tim" instead of "home/tim", probably would have had the same effect.

0

Looks Like I Spoke Too Soon Yesterday As I Woke Up This Morning And Experienced Exactly The Same Problem. I Checked The File System On The Memory Card And Everything Is There. I Changed Back To The UUID In The fstab But There Was No Change. Tried Changing The HOME Environment Variale But Also Got The Same Results..........

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.