4
Contributors
5
Replies
14
Views
12 Years
Discussion Span
Last Post by DMR
0

Mounting FAT32 and NTFS volumes in Linux are pretty much the same process.

- What distro (including version) of Linux do you use?

- What is the drive/partition layout for the system in question?

- What exact problems are you having, and what (if any) errors do you get?

- Do you have problems when manually issuing the mount command, when trying to mount via /etc/fstab, or both?

- What is the syntax of the mount command you're using?


Helpful info on issues revolving around FAT32/NTFS mounts under Linux can be found here.

0

I am using Fedora Core 3 with the FAT32 partition being hda6
this is the command that i've have tried:

"mount /dev/hda6 mnt/fat"

can anyone tell me if this is the correct command and how would i being able to read aswell as write to this partition?

0

mount -t msdos /dev/hda6 /mnt/fat

that should do the trick. I'm not 100% sure about fedora core, I'm positive it's worked in every version of RH that I've tried.

1

or, if I'm not mistaken, mount -t vfat /dev/whatever_the_hd_partition_is /mnt/wherever_you_want_it may do the trick

1

I'll ask this again for starters:

- What exact problems are you having, and what (if any) errors do you get?

If you created a folder under /mnt named "fat", and your FAT32 partition really is hda6, then mediaphyte's syntax for the mount command is correct.

In terms of the way rwx permissions work with FAT32 mounts:

The default permissions for a mounted FAT32 volume are rwx for root, but only rx for normal users.

In Linux, permission control works differently for FAT32 and NTFS filesystems than it does for native Linux filesystems (ext2, ext3, reiser, etc.):

1. The UNIX permissions of a directory onto which you mount a Windows filesystem can't be changed while the fileystem is mounted. Unmount the Windows partition; you should then be able to chmod the permissions of /mnt/Windows. You will need to set the appropriate Linux rwx permissions on the /mnt/fat folder and set the permissions for the FAT partition (as described below) in order to grant everyone write access.

2. Windows doesn't support UNIX-style permissions, and you can only apply permissions to the entire filesystem, not to individual Windows files/folders. This is done with the "umask" option of the mount command. In /etc/fstab, change the mount entry for your Windows partition to this:

/dev/hda6 /mnt/fat vfat users,defaults,umask=000 0 0

(the "users" option allows anyone to mount/unmount the drive and overrides the default , which is that only root is allowed to mount/unmount.)

- When issuing the mount command manually, the syntax is:

mount -t vfat -o umask=000 /dev/hda6 /mnt/fat


The value of the permission bits used with umask are the opposite of those used with the chmod command. For example, the following pairs are equivalent:

umask=000 and chmod 777
umask=022 and chmod 755

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.