0

hai !

i tried lot of instruction to install ffmpeg on ubuntu...

all them were failed it returns finally...

libfaac is nonfree and --enable-nonfree is not specified.

If you think configure made a mistake, make sure you are using the latest
version from SVN. If the latest version fails, report the problem to the
ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
Include the log file "config.err" produced by configure as this will help
solving the problem.

what i need to do..

help me...

3
Contributors
9
Replies
10
Views
7 Years
Discussion Span
Last Post by finito
0

Have you enabled all of the repositories in your software sources settings?
I think if you go to 'system->administration->software sources' and ensure that the universe, multiverse and restricted repositories are enabled, that might solve the problem.

Also why are you trying to build ffmpg? What's wrong with the version in the main Ubuntu repository? Have you tried installing it using aptitude or synaptic yet? I have 9.04 on my old tablet PC and it's got the version of ffmpeg from the main repo on it (I think it was part of the restriced extras package). Video playback and video conversion works fine for me!

0

Have you enabled all of the repositories in your software sources settings?
I think if you go to 'system->administration->software sources' and ensure that the universe, multiverse and restricted repositories are enabled, that might solve the problem.

Also why are you trying to build ffmpg? What's wrong with the version in the main Ubuntu repository? Have you tried installing it using aptitude or synaptic yet? I have 9.04 on my old tablet PC and it's got the version of ffmpeg from the main repo on it (I think it was part of the restriced extras package). Video playback and video conversion works fine for me!

thank u honey!

actually i am working at remote client...so that i can't get desktop gui..

can u help me how to do using command for ur below instruction...

universe, multiverse and restricted repositories

then i will try and update the result...

0

Ah, I'm at work ATM, so I don't have a *nix machine handy.

But if memory serves the list of software sources is stored in

/etc/apt/sources.list

So you could perhaps try:

sudo {insert name of preferred command-line text editor here} /etc/apt/sources.list

e.g.

sudo nano /etc/apt/sources.list

Typically if the universe, multiverse and/or restricted repositories are disabled, their entries will be commented out in the file with a #. So to re-enable them you just need to remove the # character from the start of the lines they're listed on and then save the file.


Also, going back to your original post:
With regard to the build error you're getting, it looks like you need to specify the '--enable-nonfree' option somewhere.

Unfortunately, I'm still not 100% au-fait with the way that Linux/Unix software is built using configure and makefiles. So I'm not sure exactly where you need to specify this.

As a stab in the dark, perhaps when you run configure from the command line, you need to do something like this:

./configure --enable-nonfree

Otherwise it probably needs to be added to the configure script, or the makefile somewhere.

I'm still pretty lazy and wintarded with regard to the *nix build process. I tend to use CodeBlocks project files for most of my personal programming projects. The few other bit's of *nix software I've built from source using configure and makefiles have had simple dependencies, so I've had no reason to mess with any of the configuration or makefile scripts. But I really aught to knuckle down and learn more about the whole process at some point!

Cheers for now,
Jas.

0

OK. The reason I mentioned adding the repositories was because I thought that perhaps you didn't have the libfaac library on your machine. I was thinking that you were having trouble getting the libfaac library.

As mentioned in my previous post, after reading your first post again, it's obviously an error being reported by configure. The option --enable-nonfree needs to be specified somewhere to enable libfaac to be included in the build process....But as I said in my last post, I'm not sure where this needs to be specified.

However, now that you have the other repositories enabled, instead of building ffmpg from source, perhaps you could just use synaptic or aptitude to install the restricted extras package instead?
e.g.

sudo apt-get install ubuntu-restricted-extras

That should install the restricted extras (extra multimedia codecs and plugins etc), which will also install the ffmpg libraries which the gstreamer ffmpg plugin depends on.

The restricted extras package was all I needed to get ffmpg onto my Ubuntu 9.04 tablet! None of that building from source nonsense required. It may be worth a try!

Cheers for now,
Jas.

0

sorry brother ...

every thing was disappointing me...

can u give any url to start ffmpeg installation proprly and avoid irrtitation...

during installation this error also coming...

Couldn't find package libopencore-amrnb-dev

can u give any excellant guide to start and finish successfully!!!

0

Ah, still no luck eh?

Hmm, I think I'm just about out of ideas!
Like I said installing the restricted extras was all I needed to do to get ffmpg onto my tablet PC. I can't really think of anything else offhand.

Otherwise, you'll have to persist in your attempts to build ffmpg from source....Perhaps the Ubuntu forums might have some better answers for you!

Sorry, I've been unable to solve your problem! {epic fail!}

Cheers for now,
Jas.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.