1

Hi guys,

I've experienced a problem when I tried to install Ubuntu 10.10, Fedora 14 onto my Sony Vaio laptop. Problem was, I was never able to anything on the screen. It was just full black screen. I've solved the problem and want to share with everyone.

Note: This for Ubuntu 10.10 dual boot with Win 7. It was done with wubi. I didn't bother installing Fedora because I wasted 3 days already.

1. Login to Windows.
2. Unzip Ubuntu iso file into a folder and put iso file into folder as well because wubi sometimes fails when iso is not there.
3. Run wubi and install it.
4. When you restart your computer you'll see full black screen.
5. Attach an external monitor to your laptop. Now you see everything.
6. Finish installation.
7. Download your driver from NVIDIA website. It is a .run file. Save it into your home directory.
8. Do ctrl+alt+F2
9. sudo /etc/init.d/gdm stop
10. sudo sh /home/inanzengin/NVIDIA-Linux-x86_64-260.19.29.run (You can change the file name)
11. If you face error messages, don't worry just say OK and Yes to everything.
12. Restart computer and disconnect external monitor. Nice, all visible now.
13. When you login to Ubuntu open terminal.
14. sudo nano -w /etc/modprobe.d/blacklist.conf
15. Add this line at the end of the file-> blacklist nouveau
16. sudo reboot
DONE.

If you ever see notification anywhere to activate "NVIDIA accelerated graphics driver" IGNORE it because otherwise, you start from 0 again.

Regards

3
Contributors
4
Replies
5
Views
6 Years
Discussion Span
Last Post by rubberman
0

You sir are my savior, this method gives you resolution fix and nvidia x access/config

Geforce 425M on a vaio vpcf136fm
Running a fresh updated install of ubuntu maverick

0

I originally tried to accept the update from ubuntu's additional drivers, but after reboot it gave me a blank screen. I wonder if it was defaulting display output to my vga port instead of my built in display

0

Yes, there has been a lot of chatter on the boards (linuxforums.com for example) about this. My solution was similar, but different - I removed the nouveau driver altogether, along with any other installed nvidia pieces, switched to runlevel 3, installed the proprietary nvidia driver, and rebooted. Still, a real PITA, for sure! The nouveau driver is still not ready for prime time. Sometimes it gets worse. On my RHEL 6 workstation (actually running Scientific Linux 6), the kernel had nouveau parts built into it, not as modules, and nVidia won't install with it that way, so I had to get the kernel source, modify the configuration, rebuild, reinstall the kernel and modules, reboot into runlevel 3, and then install the nVidia driver... Fortunately, there were other changes I needed to make to the kernel, so it was a wash, time-wise, but for normal users? Gag!

Anyway, thanks for the post. I'm going to make a copy and post it elsewhere when this comes up, if you don't mind.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.