0

hi
I'm learning new language right now and i want to type in it , I'm using ubuntu 10.10 and I downloaded the language (Korean language) but when i type things I get the English letters not the Hangul ones , so how can I type in Hangul ??

3
Contributors
7
Replies
8
Views
6 Years
Discussion Span
Last Post by alaa sam
0

Set your keyboard preferences and add a layout which supports hangul. On my phone atm, and can't remember the exact steps! Will post again later if nobody else posts more detailed instructions.

1

Assuming you're using Gnome:
1. Go to 'System->Preferences->Keyboard'
This will open the keyboard preferences window
2. Click on the Layouts tab
3. In the layouts tab select the 'Add' button.
This will pop up a dialog where you can set up the keyboard layout for whatever country you like. In this case, you want Korean!

Once you've done that, you simply set which of your keyboard layouts you want to use. I think there's a 'keyboard switcher' panel widget which you can put into a desktop panel and use to instantly switch between any keyboard layouts that you have set up.

If you're using KDE or any other desktop/WM, there will be a similar tool somewhere in the options to allow you to set your keyboard preferences.

Edited by JasonHippy: n/a

0

what I did was exactly as you said , but still when I switch to Korean language it types English letters instead of Hangul ones , SO what else I'm supposed to do ??
Thanks a lot for your time

0

Mmmm actually I'm using Linux /Ubuntu not windows so I can't do what you mentioned .
Thanks a lot for your participating .

1

You said you had the language pack, but I wonder if there are some additional libraries that you still need. You could use apt-cache search korean to see what other libraries are available. You might want to try using 'hangul' as a search term too. Install any related libraries you don't already have using the apt-get install command. I think some of the multi-byte languages require input method libraries, so installing any of those that appear in your korean/hangul searches may help. The only other thing is a font, but I would have thought that would be in the language pack.

Edited by JasonHippy: n/a

0

You also have to change your LOCALE environment variable in your ~/.bash_profile and re-login. Also remember that input for Hangul either requires multiple input keys for one ideograph, or a chorded key input (multiple keys at a time, such as shift-alt-something). I set up systems for this on QNX and Unix many years ago (early 90's) and haven't futzed with it since, so my technical expertise in this area is not up-to-date.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.