SphirosOkelli 0 Newbie Poster

I have been working on a linux/unix course. I am an apprentice at a server administration company and part of my homework is related to Xserves and how to use them. I have been stunted in my attempts because I cannot get NX to work. I have a windows 7 pc and I have been attempting to use NoMachine's version of NXclient to open an xterm on a linux server where my homework assignments are kept. I installed the NX client on my computer and have been told that the servers at school are equipped with an Xserver that I should be able to connect to. After the client starts up it tells me that the session start failed. These are the details:

START DETAILS

NX> 203 NXSSH running with pid: 4128
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
NX> 200 Connected to address: 128.82.4.244 on port: 22
NX> 202 Authenticating user: nx
NX> 208 Using auth method: publickey
Welcome to Ubuntu 11.04 (GNU/Linux 2.6.38-10-server x86_64)

HELLO NXSERVER - Version 3.2.0-74-SVN OS (GPL, using backend: 3.5.0)
NX> 105 hello NXCLIENT - Version 3.2.0
NX> 134 Accepted protocol: 3.2.0
NX> 105 SET SHELL_MODE SHELL
NX> 105 SET AUTH_MODE PASSWORD
NX> 105 login
NX> 101 User: kberry
NX> 102 Password:
NX> 103 Welcome to: sirius user: kberry
NX> 105 listsession --user="kberry" --status="suspended,running" --geometry="1366x768x32+render" --type="unix-application"
NX> 127 Sessions list of user 'kberry' for reconnect:

Display Type Session ID Options Depth Screen Status Session Name
------- ---------------- -------------------------------- -------- ----- -------------- ----------- ------------------------------

NX> 148 Server capacity: not reached for user: kberry
NX> 105 startsession --rootless="1" --virtualdesktop="0" --application="xterm" --link="wan" --backingstore="1" --encryption="1" --cache="16M" --images="64M" --shmem="1" --shpix="1" --strict="0" --composite="1" --media="0" --session="sirius" --type="unix-application" --client="winnt" --kbload="pc105/en_US" --keymap="en_US" --keyboard="pc105/en_US" --aux="1" --screeninfo="1360x700x32+render"

Could not find ':' in DISPLAY:
NX> 1000 NXNODE - Version 3.2.0-74-SVN OS (GPL, using backend: 3.5.0)
NX> 700 Session id: sirius-2025-53FC77F7D7EA4D87BFC0175268333436
NX> 705 Session display: 2025
NX> 703 Session type: unix-application
NX> 701 Proxy cookie: 9b0591cdcdc2894a89f0b00c00c6f5a5
NX> 702 Proxy IP: 128.82.4.244
NX> 706 Agent cookie: 9b0591cdcdc2894a89f0b00c00c6f5a5
NX> 704 Session cache: unix-application
NX> 707 SSL tunneling: 1
NX> 1004 Error: Session did not start.
NX> 596 Session start failed.
NX> 999 Bye
NX> 280 Exiting on signal: 15

END DETAILS

I have ensured that all old processes have been killed, I have created brand new connections each time I have tried to start an xterm.

I really would like to get an xterm started and I am scrambling to get this figured out. The best suggestion my prof can give me is to kill the NX processes- which I did- and check my firewall. Are there any other possibilities?

Thank you so much!!!!

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.