0

Hello All, As you can see this is my first post. I seem to be having a problem with my screen resolution in KDE. I am using a Optiplex GX280, with Integrated Intel Graphics and a 19" LCD made by Dell. The monitor suggests I uses 1280x1024 and that is what I use in windows. However, when in Linux I cannot get it to display at that resolution. 1024x768 tops. I have edited my XFree86 file, I actually took out all options for resolutions and left only 1280x1024 and still no luck. I am using Debian and no matter which window manager KDE or FluxBox, I cannot get it to display higher than 1024. I haven't tried Gnome, but I expect the same results. Any help is appreciated.

Thanks

3
Contributors
4
Replies
5
Views
11 Years
Discussion Span
Last Post by analogdog
0

Hello All, As you can see this is my first post. I seem to be having a problem with my screen resolution in KDE. I am using a Optiplex GX280, with Integrated Intel Graphics and a 19" LCD made by Dell. The monitor suggests I uses 1280x1024 and that is what I use in windows. However, when in Linux I cannot get it to display at that resolution. 1024x768 tops. I have edited my XFree86 file, I actually took out all options for resolutions and left only 1280x1024 and still no luck. I am using Debian and no matter which window manager KDE or FluxBox, I cannot get it to display higher than 1024. I haven't tried Gnome, but I expect the same results. Any help is appreciated.

Thanks

The problem is most likely with your monitor. You'll need to find out what the specifics are for your monitor (horizontal and verticle settings) and input those manually into your XFree86 file. The problem with Linux is that most hardware vendors do not make drivers and hardly ever support linux.

If you configure your monitor in the KDE Control center under peripherals you may be able to fix this problem.

Give that a try. If you can't get it to work and still want to stick with Debian...I suggest giving Ubuntu or MEPIS is go.

0

What you may want to do instead of manually editing XF86.config is to run dpkg-reconfigure xserver-xfree86. that will take you though the Debian setup of XF86, which is pretty darn good if you ask me.

Messing about in X's setup files is pretty dangerous, as they can be touchy about how they work. so using Debian's tool is a good bit safer.

Then, I would find out the max resolution of your monitor and set up XF86 to accept those parameters.

Another thing to do is to query google about your monitor and XF86 and see what others have done.

0

I find the Debian tool to be overkill...especially when you can use KDE in the desktop environment instead of dropping to the shell to do a dpkg reconfigure. Sure it's a useful tool...but why drop to the shell ifyou don't have to?

Try finding your monitor in the monitor list...before you do so, make sure you use synaptic of kpackage to update all of your software...then find your monitor and restart X by logging out and logging back in (or use control alt-backspace to do a quick restart). You should then be able to change your desktop resolution to one that your monitor supports.

0

I just use another KDE tool to give me a console window, as I can scroll back, something that the console itself does not allow.

And while we are on it, I have found many of the KDE packages to not work as advertised when used, leading to some problems.

Besides, I rather like the command line. Not all the time, but from time to time, I am very happy to have it. And for certain tasks, and scripting it rocks.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.