0

Hello :)

I just installed bind9 on my ubuntu server.

I can reach my domain fine, from any computer at home (i have fine result when trying to run:
"dig @my-public-ip mydomain.com").. But i can't reach my domain from outside (vpn)..

Do i just need to wait, for the "root-servers.net" to "index" my dns server.??

as said.. i can reach my domain at home with no problems..
the forlowing commands responds just fine:
dig @10.0.0.10 mydomain.com (local ip)
dig @my-public-ip mydomain.com
dig @ns1.my-other.domain.com mydomain.com ("ns1.myotherdomain.com" is hosted on joker.com.. and a A records is pointing to my public ip.)

Edited by brugernavn

4
Contributors
7
Replies
42
Views
4 Years
Discussion Span
Last Post by CimmerianX
0

What do you mean by root servers indexing your domain name? If you have registered a public domain name with a registrar and created at least one NS record and A record pointing to your public IP address that your DNS server is listening in then the root servers will propagate the changes across all root servers.

Have you established the domain name and NS record(s) for this public domain name?

0

yes,

mydomain.com is a public domain (registered at joker.com)

mydomain.com's name-server is: ns1.otherdomain.com (It can also be seen on a whois lookup)

and the zone-file on my server looks like this:

$TTL    86400
@   IN  SOA ns1.otherdomain.com. postmaster.otherdomain.com. (
             213526     ; Serial
             604800     ; Refresh
              86400     ; Retry
            2419200     ; Expire
             604800 )   ; Negative Cache TTL
;
                NS      ns1.otherdomain.com.
                MX  10  mta.otherdomain.com.

mydomain.com.       IN    A     my public ip
www                       CNAME mydomain.com.

otherdomain.com uses joker.com's dns servers.. with forlowing records:

ns1 IN A my public ip
mta IN A my public ip
and so on.

So i just need to wait for the root servers.
Then my domain will be visible?.

//sorry, English is not my primary language :)

Edited by brugernavn

0

You also likely need a static IP address associated with the domain name. FWIW, 10.0.n.n addresses are not routable externally from your internal network. You will need to create firewall rules to allow certain ports in your router/firewall to be associated with specific hosts inside your network. So, what exactly are you trying to accomplish?

0

I do have a static public ip.
The firewall is turned off (it's a test machine)
Port 53 is port forwarded to the bind9 server.
The only place where i uses my internal ip.. is when i portforward 53 to the bind9 server.

The only thing i missing in the "configuration" of bind 9 is a reserve zone. (but that's not a issue, or is it?.)

But mydomain.com is still not visible in public.. Wich i dont understand.

Edited by brugernavn

0

If you want mydomain.com to be "visible" you first need to take care of creating the zone delegation with your Registrar. You have to create the appropriate a NS records with them to point to your zone to your bind server's public IP.

0

But i allready done that ?

whois data for mydomain.com:

**Domain**
Name    mydomain
Status   REGISTERED (What this means)
Registered  September 25, 2013
Expiry Date September 30, 2016
Last update November 9, 2013, 6:16 pm

**Registrant**
Name    Fname Lname 
Organisation    otherdomain.com
Language    English
Address My happy adress
Phone   My phone
Fax 
Email   postmaster@otherdomain.com

**Onsite**
Name    Fname Lname
Organisation    otherdomain.com
Language    English
Address My happy adress
Phone   My phone
Fax 
Email   postmaster@otherdomain.com

**Registrar**
Organisation    CSL GmbH Computer Service Langenbach joker.com
Website www.joker.com


**Name servers**
ns1.otherdomain.com (Points to: my public ip)

Acording to the whois data.. mydomain.com is pointing to my server?

0

Name servers
ns1.otherdomain.com (Points to: my public ip)

I assume this is the IP address of the server running bind.

How about a few sanity checks.
1. curl http://www.icanhazip.com and verify that you are using the correct external IP.
2. install chromium-browser. SSH -X to the server and run chromium borwser. www.canyouseeme.org will check ports on your IP. YOu can check port 53 to ensure it is opened properly.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.