0

I recently installed ubuntu 13.10 onto a desktop computer - dual boot with windows 7 - , however the system would always fail to connect to my wifi network. I decided it would be better to upgrade to 14.04 before trying to fix any problems, and at first 14.04 appeared to have the same problem. It did, however, connect on second try! But I have since only been able to connect perhaps 50-60% of the time, and often it will disconnect after some time. This is extremely frustrating, and over the last couple of days I have been wanting to ssh to the system to play with the nix terminal and become aquainted with git + bitbucket and/or github. My network never fails to be found, it just often fails to connect! The system uses the following wifi reciever - Edimax EW-7811UN 150Mbps Wireless Nano USB Adapter - and it works fine on windows 7! I am guessing it is either a driver problem or an ubuntu bug?! I have tried to go to additional drivers and change to the broadcom listing , but that always fails to change.. what would you advise? has anyone experienced this problem?

4
Contributors
20
Replies
96
Views
3 Years
Discussion Span
Last Post by jah666
1

Click Here

Let me know if it worked

EDIT: Something that might come handy is this found it on comments where couple of people had solved the issue following that link

it says to blacklist the rtl8192cu (or approximate) driver which is the driver I have currently functioning (same model and everything). I had to instead blacklist ath and ath5k.

Edited by Slavi

0

Hey, thanks!

unfortunately I have encourented a problem "compile make driver error 2 please check error message" I think it was this, but I cant recall. This is something others in the comments section have mentioned. I will try again shortly though.
Any ideas on what the problems with installing it could be?

0

There seems to be quite a few issues with it, I just tried again and took a screenshot!

Attachments screenshot.png 579.95 KB
0

It's difficult to debug the code because we don't know what data type .ndo_select_queue or rtw_select_queue are. One thing you could do is grep the project for -Werror and remove them. At least warnings wont be treated as errors. Anyther thing you can do is use ctags to look for the two symbols in question, and change .ndo_select_queue to the correct data type.

Also can you post the complete error message? Or attack a log? That might give a little more information.

0

I will do this tomorrow as its a bit late tonight, however, I might end up just buying a new piece of hardware! the drivers seem to be outdate every version since who knows when! what hardware has good linux support and is a bit of a bargain?

0

I haven't run into many problems since 2008 tbh. You can check around here if you want. Or you can see what the store offers, and google "<card name> ubuntu" and see what comes up.

0

Do you use the same wifi receiver?!
I am sorry, I forgot to do the thing I said I would! I just recently started using linux again and I spent all day playing with it. If you do use the same receiver, can you tell me what operating system/ distro/ kernel version you are on? thanks!

0

Do you use the same wifi receiver?!

No. What I ment was I haven't ran into many wifi driver issues since 2008-ish. So a local store will almost certianly have something usefull. I use Ubuntu 14.04.

0

alright, thanks for the reply! I'm not sure if I should mark the post as solved or not, since my original problem remains unsolved?

0

I have tried to fix it yet again and I'm really just wasting too much time on this, so I have decided to just buy a new one after all. does this device have good support for recent versions of ubuntu?

TP-Link TL-WN881ND 300Mbps Wireless N PCI Express Adapter
I read a review that said it had good linux support, but it was an old review.

1

I'n not 100% sure. However, most of the TP-Link models PCI models seem to work with Ubuntu (see here) so I'll say probably. If it does work, add the info to that page so others will know. Good luck.

0

Thank you very much, I'll make sure to do just that! perhaps someone should create a list of poorly supported devices too?

0

Yup, look into that list and you'll see devices that are not supported! Add yours if it's not there.

0

cool stuff, thanks for letting me know about this! I'll definitely add a notice there after I have a look through it. Probably better to leave it til tomorrow, its after 1am and I'm too tired :) Thanks for all your help!

0

I am using TP links as well, no problem with any platform(Windows 7/8, Ubuntu,Kali and Elementary os)

0

At first I had trouble, but it appears to have been unrelated to the new tp link receiver! Was ust unfortunate timing for some other issues. After some days of use I have concluded that the new hardware works well! Thanks for all the input people, much appreciated :)

0

I hava an asus x401A. installed ubuntu 12.xx, wireless works fine,rt2800pci. Decide to upgrade to 14.xx the drivers name is not listed on connection info and the wireless keeps cutting off espesically if the computer was on sleepmode. Most of the time I have to restart the laptop or disable the wireless then networking wait for a minute or so. Then enable it. I think it is just a software bug.....

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.