I recently created a post thinking I had blown up my bootloader but I've actually narrowed the problem down to the SSD on which my home directory is mounted. The reason my computer has not been booting is because my system is not mounting my home directory's SSD. This started after I opened my box and installed a new SSD which is now unplugged and not being used. Every since I opened my box my computer wouldn't boot again. I edited /etc/fstab while booted in a live USB and commented out the line telling my computer to auto mount the SSD drive to /home/user/. After that my computer has booted up just fine, except that I'm given a generic home directory without all of my files.
When I try to mount the drive manually this is what I get.

user@mothership ~ $ sudo mount /dev/sdd1 /home/user/
mount: special device /dev/sdd1 does not exist
user@mothership ~ $ dmesg | tail
[ 1104.937031] sd 11:0:0:0: Attached scsi generic sg4 type 0
[ 1104.938166] sd 11:0:0:0: [sdd] 488397168 512-byte logical blocks: (250 GB/233 GiB)
[ 1104.939159] sd 11:0:0:0: [sdd] Write Protect is off
[ 1104.939165] sd 11:0:0:0: [sdd] Mode Sense: 28 00 00 00
[ 1104.940154] sd 11:0:0:0: [sdd] No Caching mode page found
[ 1104.940158] sd 11:0:0:0: [sdd] Assuming drive cache: write through
[ 1104.948053]  sdd:
[ 1104.951038] sd 11:0:0:0: [sdd] Attached SCSI disk
[ 1105.150165] EXT4-fs (sdd): no journal found
[ 1124.237071] EXT4-fs (sdd): no journal found

And when I plug the device into my fron USB ports this is what I get

Error mounting /dev/sdd at /media/user/86e3838b-7c18-4870-8a7b-684255629264: Command-line `mount -t "ext4" -o "uhelper=udisks2,nodev,nosuid" "/dev/sdd" "/media/user/86e3838b-7c18-4870-8a7b-684255629264"' exited with non-zero exit status 32: mount: wrong fs type, bad option, bad superblock on /dev/sdd,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

Any ideas? Thanks. I know I'm a pain.

Recommended Answers

Did you fsck all partitions on that drive?

https://www.google.com/search?q=bad+superblock+on+%2Fdev%2Fsdd%2C&ie=utf-8&oe=utf-8#q=bad+superblock+on+/dev/sdb,+site:ubuntuforums.org finds it's not an unknown problem but I can't find one answer to go with but one. Wipe and start over.

Jump to Post

All 3 Replies

It's a dual boot PC? If yes maybe Windows system is sleep or hybrid sleep not succesfully shut down.

What do you get when you run fdisk -l? do you have partitions on the drive?

Usually the drive is partitioned, and you'd mount /dev/sdd1, not /dev/sdd, which it looks like it's trying to do.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of 1.20 million developers, IT pros, digital marketers, and technology enthusiasts learning and sharing knowledge.