0

Hi -

I have an hp LaserJet 2200d connected to a RedHat Linux 8 machine, set up via CUPS. The printer is being shared over the network. Duplex printing is turned on (it's a feature I use quite often). I'm using the driver "HP LaserJet 2200, Foomatic + gimp-print(en)" Everything works perfectly except with mozilla.

If I try to print from any program (e.g. a text editor, word processor with graphics, etc etc) it all prints fine. However, whenever I print a webpage directly from mozilla, it spits out about 6 blank sheets and THEN prints the document. When it spits out these 6 sheets though, it does so as if it was doing duplex printing. e.g it'll spit it out, and then suck it back in as if to print on the reverse side, and then finally spit it out. Meanwhile, it's blank!

When it finally gets around to printing the webpage, it always prints it perfectly (e.g. graphics, no distortion, etc). However, it's just a real pain to have to wait for two sides of about 6 blank pages to come out, and then to have to constantly put the paper back into the tray each time I print a webpage.

Is this a problem with the driver I'm using? As I said, everything prints out perfectly, and this problem is only with mozilla? I just upgraded from mozilla 1.0.1 to mozilla 1.2.1 and there's no difference.

2
Contributors
3
Replies
5
Views
14 Years
Discussion Span
Last Post by Tekmaven
0

Naa, I like mozilla. But, just out of curiosity, I tried printing a webpage from konqueror, and it worked with no probs. Everything else seems to work too - just not mozilla!

When I go to the mozilla print setup screen, I see that it's set up to use the command "kprinter -stdin" and to use the CUPS printing system.

btw, why the addiction to konqueror??

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.