that, unfortunately, I have been entirely unable to find a solution to.

(Note: once again I find that this could probably fit into several of the *nix forums, so I tried my best to find the one that fit the problem best. My apologies to the mods if this doesn't fit here. ^_^U )

Here's my problem. I apt-get upgrade d recently, and ever since my xorg has been unabe to function. It prints out:

(EE) Failed to load module "nvidia" (module does not exist, 0)
(EE) no drivers available.

Fatal server error:
no screens found
XIO:     fatal IO error 104 (Connection reset by peer) on x server "0:0"
            after 0 requests (0 known processed) with 0 events remaining.

This seems to be a pretty popular problem these days, and I figured it was because my xorg was upgraded and my nvidia drivers were not. So I upgraded those, too. I ended up upgrading my kernel a bit in the process, but the output and result has not changed a bit since then - I still don't get x-capabilities.

uhm... any ideas would be great. I did follow the instructions on http://wiki.debian.org/NvidiaGraphicsDrivers#Libraries, and don't know how to fix it anymore. I've been at this for 4 hours.

JIC, here's a copy of my xorg.conf file.

#blablabla all kinds of blather in comments

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard'
Driver "kbd"
Option "CoreKeyboard"
Option "XkbUles" "xorg"
Option "XkbModel" "pc104"
Option "XkbLayout' "us"
EndSection

Section "InputDevice"
Identifier "configured Mouse"
Driver "mouse"
option "corepointer"
Option "Device" "/dev/input/mice"
Option "Protocol' "ImPS/2"
Option "Emulate3Buttons" "true"
EndSection

Section  "InputDevice"
identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "nVidia Corporation NV17 [GeForce4 440 Go 64M]"
Driver "nvidia"
BusID "PCI:1:0:0"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-38
VertRefresh 43-72
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation [NV17 GeForce4 440 Go 64M]"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "800x600" "640x480"
EndSubSection
EndSection

Section "Server Layout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

and my /etc/modules:

#/etc/modules: kernel modules that should be loaded
#at boot time, one per line. Lines beginning with "#" are ignored.

loop
sbp2
nvidia

This is on kernel 2.6.18-5-486, with nvidia-kernel-2.6.18-5-486 installed.
if I glxinfo |grep rendering , I get Segmentation Fault Mmmm... I love hearing those words.

Again, any help would be highly appreciated. I will probably be using ssh to do the things I need to right now, but of course the faster this works out, the faster I can start using my computer again.

What happens when you modprobe nvidia ?

I think I tried that... let me boot into the other system a minute and find out... I'm so glad I left this old 64-bit system on another partition...

[EDIT] Okay, um... nothing? I type modprobe nvidia and get no output. Plus - nothing happens. For some reason my wlan interface is going all screwy now, too. I can only get it to work when I boot this system in single-user mode. Son of a... this is annoying. That'll teach me to apt-get upgrade blindly...

SIDE NOTE: Is there any way I can like ssh to the other partition or something like that, so I don't have to reboot everytime I need to do something?

[EDIT] Okay, um... nothing? I type modprobe nvidia and get no output. Plus - nothing happens.

That means that the kernel located the nvidia module and loaded it successfully. Have you tried shutting down X, modprobing nvidia, starting X again, and then looking again at the rendering information of glxinfo?

SIDE NOTE: Is there any way I can like ssh to the other partition or something like that, so I don't have to reboot everytime I need to do something?

You can't ssh into an operating system that's not running. :icon_wink: You could of course boot the partition from something like VMWare Player, but that's another can of worms.

Have you tried shutting down X, modprobing nvidia, starting X again, and then looking at the rendering information of glxinfo?

Well, I've tried, but the whole problem is X won't start at all. I could try modprobing nvidia and then trying to start X, although I think I already tried that... I'll give it a shot a minute. Be right back...

[EDIT]nope. I can modprobe nvidia as many times as I want, but it won't change the fact that X won't even start. God, wouldn't it be nice if it were that simple, though? ^_^ I'll keep seeing if there's anything I can find out, maybe it's a dependancy problem, or a bug in something.

WAIT! I did notice that, of late, my ldconfig keeps giving me an error message. I dunno what ldconfig is, or what it does, but I have a feeling that it's important. Every once in a while, on that system (the one that's half-dead), I get the error message ldconfig: /usr/lib/libphysfs-1.0.so.1 is not a symbolic link. Could this maybe have something to do with it? I know it puts this message out almost every time I apt-get anything, when I try to open gtkpod (I think...), and during boot-time while the system is trying to "Creating NVIDIA TLS links..."

Thanks again for any help. ^_^

I'm assuming you checked this:

Check that you have device files /dev/nvidia0 and /dev/nvidiactl:

$ ls -l /dev/nvidia*
 crw-rw----    1 root     video    195,   0 date /dev/nvidia0
 crw-rw----    1 root     video    195, 255 date /dev/nvidiactl

I also found this:
http://www.nvnews.net/vbulletin/showthread.php?t=72490

... ensure that your system meets the following requirements:
<snip>

  • the pkg-config and xserver-xorg-dev packages are installed
  • the nvidia-glx package has been uninstalled with the --purge option and the files /etc/init.d/nvidia-glx and /etc/init.d/nvidia-kernel do not exist

If you didn't do this before you installed, you should uninstall first, set it up correctly, and then try again.

Additionally, where is nvidia_drv.o located on your hard drive (if at all)?

As a last resort, you can always try installing the x86 binaries that NVidia provides:
http://www.nvidia.com/object/linux_display_ia32_100.14.11.html

Alright, delayed response. I did a lot of digging, and found out that it was an incompatability issue from my old nvidia-driver and the new version of xorg-xserver. Simple solution - install new nvidia, right? Well that isn't simple, because there's an issue with a kernel flag the nvidia drivers will try to use. See http://grizach.sc18.info/nvpatch/ for the details. Basically, the GPL-checkers that see if a module is GPL or not say the nvidia module is NON-GPL, when it requires a udelay function that is GPL-only. Figures. So, when it comes down to it, this latest upgrade made it so that I couldn't use X with my old nvidia, and I couldn't install a new nvidia. I am currently trying to install using the patch on the page I found. I'll [EDIT] when I return to X.

Thanks again, JP, but I'm afraid only time and google could tell on this one. ^_^ I did end up nuking the onld installation, but it was getting bloated anyway. *sigh* a fresh start is always nice... except with a broadcom wlan card. Once again, it's giving me a hard time. I only want 2 things! For it to work! and under the device name wlan0, not eth2! But I digress, I'm going ooc.
Post results of running the patch after I reboot.

... Okay, first of all, I am not allowed to [EDIT] my previous post.
Secondly, I have the same results after-all. I did manage to fix it this time, without a total reinstall. I ended up re-running the installation NVIDIA....run file again, until after it said it would uninstall. Then I ctrl+c. Then, instead of xorg crashing immediately, no output, it gets back to the EE - module not found 'nvidia' thingy again. So I used the backup xorg.conf file created by the nvidia installer. Now I can get back in. My 3d accel is really missed, though... I wanna play darwinia inbetween my homeworks.

I don't know why I thought it would work, but I want my 3d accel back. I'll figure it out. I have the feeling that since this would end up being a thread about NVIDIA drivers, which doesn't really fit the forum selection, I should save my breath for a different place. ^_^ I'll be back later. Any other comments on NV's non-free drivers with LENNY or just 2.6 I would love, but I dunno if they are appropriate for this forum.