Hi Folks, I've now had my powerbook for a week or so, and am very happy with my choice. I can now understand all those people who say they *love* their Apple :) .
However I have had one problem that I would welcome advice on. The problem has now occurred twice.
Running OS X 10.3.5
Click on Finder/mac help, & usually a search box plus page with OS X help & options comes up. I type into the search box, hit enter, & a list of 'help' possibilities appears. The emphasis is on *usually*. On two occasions I've clicked on Finder/mac help, the search box has then appeared but the page has been blank. I typed in the query to the search box, hit enter & then..........nothing. Hit enter again...............spinning beachball of death. I tried opening help in other applications & they worked ok.
I phoned the Apple support line, who guided me through a solution that then restored the finder/mac help function. The solution involved removing the Preferences folder from Desktop/home/library to the trash & rebooting. The preferences folder is automatically replaced, but all preferences revert to default.
The second time I again repeated this procedure succesfully, but having to restore all settings is a real pain.
Within the Preferences folder their are a list of files with the extension .plist. Can anyone tell me which one of these is likely to be the culprit. I tried just removing the 'com.apple.helpviewer.plist' & rebooting, but it didn't solve the problem.
Also if anyone has any thoughts about why this should be happening, please share.


Open up the Applications --> Utilities --> Disk Utilities and do a permissions check on the drive. There might be a whoopsie in there.


Many thanks for your reply Christian. I did as you suggested, & sure enough the disc utility told me that there were several 'whoopsies'. I did a 'repair permissions' & hopefully this will prevent the problem re-occurring.
The 'feedback' in disc utility following the repair is shown below.
Are you able to tell me (preferably in laymans terms) what a 'disc permission is or what it's function is? Any ideas on why the permissions may have been incorrect? I suspect they were incorrect when I bought the Powerbook, which was 'factory refurbished/ex-demo).
Thanks again.

Repairing permissions for “Macintosh HD
Determining correct file permissions.
Permissions differ on ./Library/Caches, should be drwxrwxrwt , they are drwxrwxrwx
Owner and group corrected on ./Library/Caches
Permissions corrected on ./Library/Caches

User differs on ./Library/Preferences, should be 0, owner is 501
Owner and group corrected on ./Library/Preferences
Permissions corrected on ./Library/Preferences

We are using special permissions for the file or directory ./System/Library/Filesystems/cd9660.fs/cd9660.util. New permissions are 33261

Permissions differ on ./System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/Resources/PACSupport.js, should be -rw-r--r-- , they are -rwxr-xr-x
Owner and group corrected on ./System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/Resources/PACSupport.js
Permissions corrected on ./System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/CFNetwork.framework/Versions/A/Resources/PACSupport.js

Permissions differ on ./private/var/log/install.log, should be -rw-r--r-- , they are -rw-r-----
Owner and group corrected on ./private/var/log/install.log
Permissions corrected on ./private/var/log/install.log

Permissions differ on ./private/var/log/wtmp, should be -rw-r--r-- , they are -rw-r-----
Owner and group corrected on ./private/var/log/wtmp
Permissions corrected on ./private/var/log/wtmp

The privileges have been verified or repaired on the selected volume

Permissions repair complete

Well Guys, I had hoped that using the disc utility, & 'repairing permissions would have fixed the problem. Unfortunately not so. However I am a bit closer to the cause of the problem. I have isolated the problem file as 'home/library/preferences/com.apple.help.plist. Now when the help viewer refuses to load correctly, dragging this file to trash, revives the help viewer functions. But only temporarily it seems. The file is automatically regenerated in the 'Preferences' folder, & sooner or later the help viewer starts to fail again. At least I'm not having to lose all my preferences as previously!
Any more thoughts guys?


A disk permission in Mac OS X is shown in the traditional Ancient Unix.

d rwx rwx rwx

The first character, is either a d or a - and this means Directory, or file.

rwx are read, write, execute

The first pair are owner, the second pair are group, and the third pair are guest/world.


drwxrwxrwx means "directory, owner may rwx, group may rwx, others may rwx".

Typically, you will see files like


This is a standard file (not a directory). The owner can do all. The group can read and execute only. The outside world can read and execut only.

SOmtimes you will see this


that means it is a file, and no one can use it!

These permissions are used in the securing of files. Something I should go deeper into on the Mac Tutorial. Thank youf or the idea.


Any thoughts on my last message (in this thread) guys?