I renamed an iMovie project folder while iMovie was minimized. When I tried to maximize iMovie it would not come back. I tried restarting to get it back with no luck. I tried to Force Quit iMovie, but is was not listed. I tried to reinstall iMovie, but the installer says it is running and to Quit the application. I tried trashing iMovie but that didn't help either. i also ran Norton Utilities and Drive 10. Nothing has helped.

I movie won't start and I can't install it. What do I do?


I knowe this probably sounds like a stoopid question (;)) but:
Have you tried rebooting your Mac?

Thanks for reading my problem and trying to help. Yes I did reboot! (see original question quoted below.)

"I tried restarting to get it back with no luck."

I guess I'll have to initialize my hard disk.... :(


Oops, yeah - sorry, didn't notice that :o

What happens when you try to start iMovie? Have you removed it's preference file?

If I click on the icon on the menu bar literally nothing happens. If I doubleclick on the application I get an error message: The operation could not be completed. An unexpected error ocurred (error code 1000).

I don't know where the preference file is in OS X 1.2.8.

(I'll look for the preference file, but I may be afraid to delete it unless it is REALLY obvious what it is.)

Thanks for your help!



OR, if you have iMovie 3


~ = your home directory.

Thanks yellow for the locations. ~/Library/Preferences/com.apple.iMovie.plist was NOT there. But, ~/Library/Preferences/com.apple.iMovie3.plist was so I trashed it.

iMovie4 app was still in Applications, so I tried it again with the same error message, so I trashed it and this time the trash emptied.

However, the installer says to quit all the iLife 04 apps, but none are running.

Do I have to remove all of the iLife apps and their preference files?

Is there someplace in the Finder that needs to be cleaned out? Like rebuilding the Desktop?

Any help is most appreciated. Thanks again for your time.


I have installed OS X on a different HD and tried to run the installer on that new HD and I got the same instruction to close all the iLife 04 apps before trying to install. It seems to be something at a very deep system level. :sad:

I had the exact same problem.

Go under the Apple menu and Log Out.

Then Log back in and immediately hold down the shift key. This will bypass the background iTunes stuff that is hanging you up. Now you will be able to reinstall your iLife apps.

Hope that helps