I need help. I recently upgraded to OSX 10.2.8 after installing my computer froze and I got an error message. it includes the date plus "init:can't exec /bin/sh for single user: Exec format error"
I have tried booting from CD, using various keyboard commands and nothing has work yet, any help would be greatly appriciated. Thanks
Sue :cry:

What version did you upgrade from? 10.2.6? Or something lower ... ??

Basically it's telling you that it can't start the bash (I think sh is bash?) shell. Have you tried going into the Disk Utility and correcting permissions for your system partition?

Hey Dani,

What about Zapping the PRAM? If I'm not mistaken, you boot it up with the disk in, hold down the Apple, Option, P, and R keys at the same time and let it restart 4 times. On the fourth time you hear the start up sound, you let go of all the keys and it should boot from the CD.

I think......

Correct me if I'm wrong. I don't know it all and am always willing to learn more. I haven't had to zap the PRAM in a Mac since using OSX, so I may not have the key combination right.....

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.