help much needed ... i just bought myself an iMac for my dorm room and I can't for the life of me find a nice, freeware ftp client for OS X (jaguar)

pleeeez help !!

Recommended Answers

All 14 Replies

try deleting '' in the browser's location/address bar in replace it with '' - naturally replacing the ip addy as appropriate. Then user the browser as a Windows Explorer session (i know ur using OSX) where u just drag & drop files as needed, assuming u have the authorizations.

The first thing I tried was using Internet Explorer as an ftp server, and it didn't work at all :( At first it worked ... but then what it started doing was if I were to click on a folder, the folder icon would just disappear and show 0 files as the contents ?! It was getting very weird on me. Sometimes it worked, sometimes it didn't. Very quirky (just like IExplore for Win is when using it as an ftp client). Which is why I figured I needed a real ftp client ... and to my amazement they aren't popular for the mac at all ?! I'm thinking about Fetch ... I emailed them and got a free key for student/academic use.

netscape (4.7) has been pretty stable for me - then again i'm the one that still uses win98 on my pc's, so... fetch seems to be pretty popular for macs, havent used it myself tho.

Well ... I figured out what my problem is !! I tried using Fetch, and it looks as if my campus has firewalled me from OptOnline (boo hoo) - other ftp sites work tho ... so at least I know it's not me that's the problem!!

Well, I've been using fetch for awhile, but I'm having some grievances against it.

First, it's not drag 'n' drop compatible? Second, how can I go up a directory - I'm looking for an ".." symbol somewhere I can click on, but it seems like it wants me to constantly be using the dropdown menu when browsing. Very obnoxious.

Also, anything that'll support s2s or fxp? Looking for a powerful ftp client and coming up very short.

I can't access the link. I'm getting a 404 error :/

I just clicked the link and connected straight away - are you using the correct mouse button?! :P

I guess the site was down or something, b/c it's working for me now too. Unfortunately, the site doesn't help me at all :( It just seems to show how to use an old version of Fetch - and I still can't find any .. for it :/ weird; thanx anyways! :)

Try searching on for an ftp client called FTP Thingy. It doesn't look super powerful, but it has a nice interface for going up and down file structures. Not sure if its drag 'n drop, though. It has an ugly-ass icon, that's for sure...

Well, it's over a year later, and I now have a nice, shiny new G5. Problem is, I still can't find an ftp client I'm happy with. I've been using fetch, but it doesn't suit all my needs exactly.

I'm looking for something similar to the features/functionality/appearance of SmartFTP for Windows. Fetch just seems to be an aqua version of gftp (for linux). ;)

Well as already referenced, Panic has a good FTP client called Transmit which is now up to version 2.6,

that would be well worth your time to download and try. Heck if you have a G5, whats $25 for a product you like? I spend well over $25 going to dinner w/ the wife. I'm sure you will like this app. Very gui friendly. And hey you can go up a directory with one the click of a mouse!

Thanks. I must've overlooked it when aeinstein posted. It does look a lot more robust than Fetch (which I'm using for free as a licensed educational user). Panther is being delivered to my house within the next day or so, so once I install it and get my OS in working order again, I'll def. consider purchasing Transmit.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.