I am having a lot of trouble with Panther and I cannot for the life of me figure out what the heck is going on. It worked fine when I first installed it and then programs began to cease functioning after about two weeks. (MS Office, Safari, the Mac help system, Macromedia Studio 2004, and on and on. There seems to be no rhyme or reason for any of this. Some of the programs simply fail to load. An others error out and pop up a crash message. I tried a clean install (in the process loosing a lot of valuable data because the backup somehow got corrupted. Apple used to have the best customer support in the free world but now I cannot get an answer from anyone. Perhaps you can help me. The machine, by the way is a new G4 with 1 Gig of memory. I have an 80 gig firewire disk and an 80 gig hardrive installed.


I have found that a bunch of programs crash on startup when they're not Panther compatible. Something to try is to use the system recovery disks to get into the Disk Utility and run the file system check and the permissions check on your drive.

I have found that a bunch of programs crash on startup when they're not Panther compatible. Something to try is to use the system recovery disks to get into the Disk Utility and run the file system check and the permissions check on your drive.

Thanks for your reply. I have run the disk utility and the permissions utility without good result. One thing I note is that the "permissions" seem to always be in need of repair no matter how long ago I ran the utility. This seems wrong to me but at any rate it seems to do no good for my problems.

I'm having problems with Panther too. Safari plist gets corrupted often. System preferences were corrupted yesterday. I tried to revert, after testing Panther on my other machine (both emacs, current being 1ghtz combo, other 700mghz combo) with Apple's tier one support that resulted in trashing that machine. Got it fixed and had to fight with Apple to reimburse me $85 for the repair.
They have changed my download options and desktop options for the worse. I think they rushed this out too soon.

From what i haver read about Panther-problems here I conclude that there is something fundamentally wrong. I have problems similar to what has been described here (disk previliges seem to be corrupted all the time, the colored disk-cursor always turn up indicating that I have to wait or make a forced shut down of a program), and I do not have any clue how to solve the problems. No result from Disk utility, no result from Norton Disk Doctor and above all no result from Apple support.

Hopefully someone with more insight in this will appear hear to solve our problems.

Bo Rutberg

I have read excellent reviews on Disk Warrior That cscgirl mentioned. I use MacJanitor, Onyx and the Apple disk utility frequently. I'm glad I got the Apple Care plan with my eMac and plan on getting one for the new one as well. The phone support has been very helpful at times and inept at others. I also have a gig of ram in both or they don't run satisfactorily with some things.

I had a flawless install of Panther, but I went againstt the grain and did a basic upgrade. Everything was just peachy until a couple weeks ago, when Safari began to slow down big time. It got to the point where 10 minutes after opening Safari, if I was on a busy website, I would get the spinning beach ball every time I clicked on a link.

I tried all the usual stuff, with no luck. Finally, I decided to try logging in as Root, and see how Safari behaved, and to my surprise, it was awesome! It was quick and snappy again, and a pleasure to use. In fact, I stayed logged in as Root for several hours so that I could get some admin stuff done at my website, and not go crazy with delays.

I figured out which files were unique to each user as far as Safari is concerned, logged back in as me, and moved them to my desktop. I then restarted Safari, and it was great again. It has been ever since.

The point I am trying to make is to try logging in as Root and see if the problems you are having still exist. I found this made the diagnosis much easier.


Take care,

The other day I went for my beloved computer and turned it on. A few minutes later everything froze up and so I manually shut it down (power button) and tried restarting a bit later. Same thing. Everytime, same thing. Not only that, it came with an error message that was completely indecipherable to me, a non-computer-guru. It was as follows:

Entering system dump routine
A panic server was not specified in the boot-args, terminating kernel core dump.
ethernet MAC address: 00:00:00:00:00:00
ip address:

Waiting for remote debugger connection.

The GUI locked completely, and that text appeared in the upper-left corner, white-on-black, overwriting the interface beneath. The whole process was instant. The machine remained running, but was absolutely unresponsive (except capslock, that button worked, I know because I could see the light).

If you can tell me anything about it besides that I should format and reinstall all of my software (the only thing that's been suggested to me and the only thing I was able to find on the internet), it would be
greatly appreciated. And if I need to format and reinstall, how do I go about it? Is there any way to back up before I format?


Have you guys put in some extra memory in your Mac? I've heard that Panther seems to have a hard time with memory upgrades. I also had the same problem myself, everything crashing, freezing and so on. I pulled out my 512mb memory card and now everything works perfect! This Panther Os X is rock solid and never have crashed since, the programs dpn't crash either.

Apparently the extra memory that works fine in earlier OS X versions such as Jaguar, does not in Panther. I called Apple Care and they "halfly admitted" the problem. Now it is just to found out which manufacturers memory Panther can handle. I had a Kingston memory installed (512mb) but apparently it was somehow faulty (Apple recommends this memory), and will get a new one next week. I know from my Mac shop that Kingston has had problems with their latest batches of memory. I hope my Panther is still as rock solid after I have installed the new one :-) I keep you posted!

what is logging in as root?

Logging in as root enables you to make greater changes to the entire system BUT you must use it with care if you don't know what you are doing!

The Root user is effectively GODMODE for the computer, you can log in as root at the login window, if you have the root password, or you can enable root user from NetInfo Manager in the Applications/Utilities folder.

Once the program is running, go to the security tab at the top and click on Enable Root User. You need an administrator password though.

Clean install Panther, often you thank yourself later that you did even if it takes some effort ;o)

I have never seen an "upgrade" from 10.2.x or earlier work. It SEEMS to work, but inevitable problems persist. Previous post is correct. Clean install.

Repair permissions EVERY time you install anything.

Has anyone actually seen Norton work in panther? I have only seen it destroy the entire OS. Also I have never seen Disk Warrior do anything but freeze. Does techtool actally fix anything? It only seems rebuild the desktop (OS9 only), and test hardware?



An interesting thread. I am running with 10.3.3 on an older laptop, and the only things that don't really work is the onboard SCSI. I have to boot into OS 9 in order to burn CD-ROMS via SCSI.

I agree with MacTecTom that clean installs from 10.1 to 10.2 to 10.3 are the best solutions, and to also often repair permissions if things start going goofy.

I have not gone with any Norton or Disk Warrior solutions. TechTool worked nice under OS 9... don't know about under OS X. I have done alright with the occasional Apple Disk utility scan, and using Retrospect to back files up on a regular basis.

For the curious, to enable the root user to login, you need to go into the NetInfo tool, and put in a blank password (remove the *, and leave it blank). Save the data.

Next, open a terminal window, and type in:

su -

It will give you a new prompt-- root#

Next, type in


and assign a password. It will ask you to type it again. You will not see any echos or dots or anything as you are typing.

ONLY use root when you really need it. For me, a network admin who uses his OS X box hourly, I might go into root user once a month, if that.


Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.