I'm having some trouble with some low-level tools. Any advice would be appreciated.

Here's the situation: I've been having trouble with screwy rendering of GUI elements in gimp. Submitted a bug, the gimp people say it's a gtk problem. Since I'd been meaning to upgrade from 10.5.8, I figured I'd go ahead and do that, and see if that took care of the gtk issue - no dice. So I checked, and gtk --version said I was a little behind, so I downloaded their installer script for the current version, and ran .configure. The script says it's having trouble with autoconf. So I check autoconf, and sure enough, it's a little ways behind, so I go to bring that up to date so I can update gtk, and autoconf wants shtools. Okay, no shtools, so I go to try to install that. shtools installs without a hitch (I put it in /etc/shtools, if that's relevant), but the autoconf installer still complains about not having shtools, and so the gtk installer won't continue. Now, and this is presumably related, Gimp won't start up - it starts X okay, and shows the startup image with progress bar, and it builds the frame for a window, then X crashes.

I suppose one option would be to do a clean install of 10.6 and see if that takes care of it, but I'd like to save that for last. Any suggestions for things to try?

Usually reformat would be the last option for mac users and if you had no choice backup your data. Try and reinstall your gimp app and delete the old one. Since when has this problem started and what were youb doing when this problem occured

The display problem has been going on for a few months - I noticed it when I had to do some image work for my job, and the menus all looked goofy and illegible.
Here's a link to my bug report - there are screen shots attached, if you want to see what the problem looks like. I've already tried reinstalling gimp to resolve this one, it didn't help.

The current problem - gimp starts to load and then crashes - is more recent, it started immediately after I started messing with gtk, autogonf, and shtools. Immediately, as in, it worked the day before, and ten minutes after I gave up on the gtk install, I tried to start gimp and it didn't work.

Just to be sure, I've just tried a fresh reinstall of the latest package from gimp on MacOS - nothing doing, same thing: gimp goes through its startup, displays a frame, and then X collapses.

The image is not clear, try posting the screen shot you capture here. And when you use Gimp is other applications on, if yes quit all other applications and see whether your Gimp is working fine

The image is not clear

Yes, exactly, that was the problem, the screen was not clear. gtk, apparently, was a little broken. But that's the old problem - gimp worked, and I was able to edit, although it was hard to find the menu items I needed.

Now, the screen shot looks like the attached error report, because the X11 is crashing when Gimp launches (yes, even when nothing else is running). As far as I can tell, Gimp is working fine, but the supporting software that it relies on - gtk - is hosed, due to my inept meddling.

Try the stable version of GTK, GTK+

Hi jon.kiparsky ,

Please ignore my previous post above as it is not relavant to your problem. Could you put your app into a folder and compress it into a zip. file. YOu can sent me the zip file via PM or post it here. I will thank analyse what is wrong with it. dO not clean install it leave it at the last option

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.