Hey guys so I purchased a WD myBook essential about a year and a half ago for my Macbook pro. I connected my laptop to a tv, (so I can play my movies through my WD hardrive). After disconnecting it, my laptop isnt recognizing my WD Essential anymore. I cant find it in Finder when plugging it in and it does not show up in disk utility so I can not format or partition it. The light is flashing on it when I plug in the power source so it i working. Same problem when plugging it in to other computers. Help!

You probably just unplugged it and didn't unmount it or select "safely remove" option from the disc icon. That probably damaged the file system. It can probably be fixed. If you don't need the data on it, you can reformat it. If you do, then you will need to get to a command line window and run fsck on the device/partition to repair the file system. The Mac may have GUI-based tools to do that, but since I don't run Macs that much, I don't know what they would be.

ok well I do not ned the data on it so how would I go about reformatting it? Thanks btw!

Since it doesnt pop up in disk utility, I dont know of any other way to reformat

Hello. Just to understand, this is a USB external hardddrive that is not working in either your Mac, or on other computers. Disk Utility is Apple's authorative program to work with devices.

Have you tried a different USB cable?

You tried it on different computers without success, so it is either the cable, or something internal to the unit.

Can't rule out the possibility of a hard drive failure due to some logical or physical corruption. You must find some utility to repair your hd, if its hfs formatted then free download Stellar Volume Repair and scan your hard drive with it.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, networking, learning, and sharing knowledge.