0

Hello my hard drive crashed, I was unable to boot to pc. Tried reinstal repair of Win xp still no luck to boot.
I added old hard drive C, set first hard drive D as slave and reinstalled again
Now I have access to my pc however no access to old My documents. Can see however all of the system files on D. Just access denied to my docs on old hard drive
The new hard drive is on Fat32, old hard drive is NTFS- could this be the reason?.

When I right click on the D: My docs folder, its tells me its empty, however when I run a program like Registry Mechanic on it, it shows that there are several folders still in there.
Have discssed it with computer shop, they say its a permissions issue

Can anyone please advise before i lose patience and reformat both drives as both now running slowly, as double xp installed now.
I am web administrator for local walking club so would ideall like access to the files but I guess if I have to reformat will do so

Another weird thing I ve noticed is that even though I changed the jumpers in my old hard drive so its acts as a slave, when I installed the Win Xp again and any files I save automatically go to the old hard drive as new folder windows xp 2 etc and Cetc my docs. Is this normal?

Any advice would be gratefully noted.

4
Contributors
10
Replies
11
Views
10 Years
Discussion Span
Last Post by isrjs
0

The new hard drive is on Fat32, old hard drive is NTFS- could this be the reason?.

yes,fat32 doesn't see ntfs!!

0

yes,fat32 doesn't see ntfs!!

Hello thank you
Is it easy to change from Fat32 to NTFS?

0

had to go back to read you first post and see you are using winxp on fat32 ,yes it can be changed to ntfs,try this site
http://support.microsoft.com/kb/307881

http://netsecurity.about.com/od/securingwindowsxp/qt/aa071804.htm

hi there all

I have now changed the master drive to NTFS.

Unfortunately, I still cannot access a folder in documents and settings, it tells me that access is denied
I have tried to drag it to the shared documents folder, but I also get an error message telling me " Cannot creat or replace Dxxx : Access is denied. Make sure the disk is not full or write protected and that the file is not curent in use. "

Any suggestions?

0

What folder is it? Try logging in as a different user(one with admin rights) and try copying it then.

0

Hi Justin
Yes sorry, I am already main administrator so that won't work.

I have also tried changing the registry with regedt and editing the permissions to folders by all user accounts and those who log on from read only to full permission with no effect.

The name of the folder is the main old hard drive - main folder for my files in sub-folder of Documents and Settings called Deirdre

0

hi there all

I have now changed the master drive to NTFS.

Unfortunately, I still cannot access a folder in documents and settings, it tells me that access is denied
I have tried to drag it to the shared documents folder, but I also get an error message telling me " Cannot creat or replace Dxxx : Access is denied. Make sure the disk is not full or write protected and that the file is not curent in use. "

Any suggestions?

I don't have any suggestions ,just a comment.i run into this when i have other people hdd with multiple users connected to my computer try to retrieve files,i get the error only on the users that had been password protected ,and tried ,right click on the folder and take ownership,as suggested here in another post ,to no avail! sorry

0

Thanks for the comment. and thanks for the advice earlier too.
I have also looked at the Microsoft advice for changing the folder permissions, by editing the advanced options in the View panel of the Folder options, unclicking or clicking simple file sharing
however maybe this doesn't work for Microsoft XP home, as when I go to the advanced options, there is no such option.
I am about to give up and reformat both drives totally. Any tips for this?, being cheeky maybe I should open a new post for this

0

First of all:
Having your new installation on a FAT32 drive has nothing to do with this issue.
The fact that you can see any files on the old drive proves that.
It is the OS that determines what file system is visible.
If you were running Win96, or Win98, then you would not be able to see any part of the NTFS drive.

Next:
Gaining access to your old data depends on which version of XP you are on.
It is easier if you are running XP Pro, but can be done in XP Home also.
No need to reinvent the wheel, so we'll use the Resolution info on this Microsoft page.

http://support.microsoft.com/kb/810881
To resolve this issue, you must turn off Simple File Sharing, and then take ownership of the folder:
1. Turn off Simple File Sharing:
a. Click Start, and then click My Computer.
b. On the Tools menu, click Folder Options, and then click the View tab.
c. Under Advanced Settings, click to clear the Use simple file sharing (Recommended) check box, and then click OK.
2. Right-click the folder that you want to take ownership of, and then click Properties.
3. Click the Security tab, and then click OK on the Security message, if one appears.
4. Click Advanced, and then click the Owner tab.
5. In the Name list, click your user name, Administrator if you are logged in as Administrator, or click the Administrators group.

If you want to take ownership of the contents of that folder, click to select the Replace owner on subcontainers and objects check box.
6. Click OK.

You may receive the following error message, where Folder is the name of the folder that you want to take ownership of:
You do not have permission to read the contents of directory Folder. Do you want to replace the directory permissions with permissions granting you Full Control? All permissions will be replaced if you press Yes.
7. Click Yes.
8. Click OK, and then reapply the permissions and security settings that you want for the folder and the folder contents.

If you are running XP Home it is a bit more difficult.
You have to boot into SAFE MODE by pressing F8 while the computer boots, then log onto an administrator account.

Once you are logged on you can follow the same Microsoft page instructions listed above.
(Just skip the part about turning off "simple file sharing")

You can change ownership to be just your administrator account or to the Administrator Group, so all admin accounts will have access to the data.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.