Basically, I cannot connect to anything using the telnet software that comes with Windows. I have enabled the telnet service and I can't work out what's causing it so I'm wondering if you guys could help. I'm using Windows XP and the error message I get is:

Could not open connection to the host, on port 23: Connection failed

Is this inside your local area network, or remote?

I'm using BT and I'm trying to use remote. Is there anyway to stop them blocking it?

Sorry about my last post 23 should be open. It is port 25 that ISPs are blocking.

You are using a CMD prompt in XP? can you ping the site?

Port 23 is TCP port. Try 80 for telnet

Yeah I'm using Command Prompt on XP. I can ping this site fine but when I try telnet on port 80 on this site, the screen goes completely black and I can't type anything.

On the server end the port must have been changed from the default.

Do you know any sites that work that I could try it out on. I tried it on LOCIS (The Library of Congress Information System) but I only get the message saying it could not connect, on both 23 and 80.

telnet time-a.nist.gov 13

This will give you the UTC time, date and then disconnect (port 13).

If you are just experimenting why not try your own mail server? I don't know who BT is, but you can find the ports that corrispond to their SMTP an POP3 servers usually 25 and 110.

Yeah that worked. Maybe the LOCIS isn't up and running anymore. Thanks for the help!

PS. BT is an ISP here in the UK. It stands for British Telecom.

Glad I could help. Don't forget to mark the thread as solved.

I'm trying to make star wars work. telnet. cannot start connection lost port 23? what is thhhhhhis