Heya all,

here's my issue: i'm trying to set up a simple server on my desktop here, but i can't seem to get it working.
I checked the router settings, and made it port forward the right ports to this computer, and that works on my internal network.
when i use ipchicken to get my router's ip, and try to connect through that, it doesn't allow me to connect.

When i browse to this external IP, i get a browser popup asking me for a username and password for -a- router, but when i insert our router's username/pw combination, it fails.

I also assured this ip is static: it's been the same for about 2 months now.

Recommended Answers

All 5 Replies

These consumer based routers are not going to support you accessing the external IP from within your network. To test this, use a browser from a device that has an external IP.

guess i could've expected that from a consumer router then, i won't be leaving home for a few days, but i'll test it out as soon as i do.

oh, and if it still matters: the router is a cisco e4200, the systems i tried connecting to so far are a windows 7 machine (minecraft server) and an openSUSE OS for SSH (so far)

I believe you are trying to access an internal server through the public ip being in the same network, for this you need to have something called a loop back NAT policy on the router, this would enable the traffic to hit the router and get back to your own network for this public ip.

What a timing, just as i wanted to post a reply, Daniweb goes into read-only...
Anyway, you're both right. i checked the router for a NAT loopback function, but no dice.

i tried accessing the webserver from the outside, but it didn't work.
I'm having 2 issues with linux now: YAST crashes when i try to update any non-essential package, and i can't stay connected to one router for longer then +/- 10 minutes.
after that, it doesn't even show up in the network manager anymore.

today, it completely refused to connect, so i installed wicd, resulting in 2 broken network managers and still no network connection :(

but to get back to the issue, i had a friend connect to my laptop (with windows 7) to my minecraft server, and that didn't work either, but the server itself works

So, it seems that you that the issue you are describing is that you are uanble to connect to your internal resource from the internet. For this to work, there are a few things you have to make sure are in place...

1) you need to know your external IP. I think you got this part since you know how to access sites that provide you with your external IP, such as http://mySourceIP.com
2) you need to set up port forwarding on your internet router. All you need to do is make sure that you know exactly which port your clients will attempt to connet to. For instance if you were running a web server on your internal network, you would configure your internet router to forward on port 80 to the IP address on your internal network that is running this resource.
3) on your internal resource, you have to make sure that the application is running and is listening on the port. Make sure that you do not have the local firewall blocking access to this port.

From an internet client, just try to test for connectivity using a telnet client. Even if your internal computer is not running telnet, you can still use this as a tool from a client. From an external internet client, running the telnet client application, connect to your external IP but on the port that you have published. For example, "telnet xxx.xxx.xxx.xxx 80" if you were trying to connect to a web server. just change the port number for the port that you are publishing. If on the telnet client it shows a blinking cursor, the port forwarding is working and the connection was made. If you were unable to connect, the telnet client would advise you that no connection was established.

Be a part of the DaniWeb community

We're a friendly, industry-focused community of developers, IT pros, digital marketers, and technology enthusiasts meeting, learning, and sharing knowledge.