0

I have been helping a coworker with a computer that lags sometimes at start-up, using windows xp professional. Checking the computer I found out that there was a missing driver, an ethernet controller driver and there is no way I can get a suitable driver that installs in that system. I tried using several programs such as drivermax, double driver, Driver Whiz, etc with no luck. This is an ASUS desktop computer with a Pentium 4 2.4 GHZ processor and Asrock Model GE pro M2 motherboard. I ran the Everest software and apparently the missing drivers are Ralink RT 2500 802.11 g wireless network adapter for wireless and SIS 900 fast ethernet adapter (Phy: Realtek RTL8201/L/BL. Any help will be appreciated in trying to install these drivers.

2
Contributors
1
Reply
2
Views
7 Years
Discussion Span
Last Post by techsheaven
0

Go here: http://support.asus.com/download/download.aspx

Rather than the Mainboard info, you will need the series # Usually on the front of the case and/or owners manual and is part of the model number. You will then need the full model #.

Alternately, you can try this for the wireless:

http://download.cnet.com/Ralink-RT2500-Wireless-LAN-Card/3000-2112_4-65181.html?tag=mncol

And maybe this for the Ethernet Adapter:

http://download.cnet.com/SiS-900-PCI-Fast-Ethernet-Adapter/3000-2112_4-92350.html?tag=mncol

Good Luck!

Post the results back here!

Edited by techsheaven: Spelling

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.