0

firstly im new to the forum..hope it turns out helpful
i tried doing a quick research over the internet for the following error but i read to many conflicting reports so i decided to come to this forum and try my luck

so i recently installed a software called tuneup utilities
it did a scan of the computer and all and i shut it down
next time i go to open it and i keep getting the following error every time i want to open ANY PROGRAM installed on my pc

"the application or DLL C:\windows]sysyem32\wsock32.dll is not a valid windows image. please check this against your installation diskette.

im running XP with service pack 3 at the moment
i cant not even see my start button nor open any programs except CCleaner
i cant even run CMD

i tried to run it in safe mood but the same issue occurs

please any help would be greatly appreciated
im using my laptop to write this at the moment

3
Contributors
20
Replies
22
Views
7 Years
Discussion Span
Last Post by gerbil
0

hi,and welcome to daniweb ,i google you error and found this ,give it a try .

Error – “Wsock32.dll (or another .dll) is not a valid windows image”

This error is a tough one as it severly limits the programs or apps that you can run in Windows. This error pops up every time you try to open a program in windows, well not every program but most. Most spyware programs can’t be ran because this error pops up and prevents it.

One would think that the solution would be to repair the invalid .dll, but what ended up fixing it for me was extracting a fresh copy of explorer.exe. It looks like explorer.exe had gotten corrupt for some reason and was causing the bad image errors with certain .dll s.

1. To repair the problem open up msconfig, it is actually one of the few programs in windows that would still open. To open it click on Start -> Run ->Type in “msconfig”. Once it is open click on the button that says “Expand File”. From there you will select the file that needs replaced and the location of the good file. Most of the time the good file can be found in the i386 folder of your XP install cd. My msconfig didn’t like the directory “C:\Windows\System32\ that was already filled in, so browse to the Windows\system32 directory and it should work just fine.
2. Expand the file, it will look like nothing happened, that is normal. Reboot the computer and you should not get the errors anymore.
3. To be safe, I expanded the Wsock32.dll file as well, so if for some reason your error still persists try expanding the dll file too.

http://www.advantage-pc.com/?p=692

Edited by caperjack: n/a

0

i actually read that blog
the issue is that i cant even see the start button
so i cant go to start and run and then type in msconfig
and i tried to do this through safe mood with command but nothing
it gave me some sort of error

0

i tried using the windows button on my keyboard....it doesnt do anything

0

Ah, then you don't have explorer.exe. :)
You can start a browser [perhaps] from Task Mgr > File, and run other commands from there. eg, enter msconfig ... And if TM is working like that, then you can access System Restore [if that will help] by pasting into TM ..
%systemroot%\system32\restore\rstrui.exe
And IE: %programfiles%\internet explorer\iexplore.exe
Got a browser? Use it like explorer, but you must enter the full path to whatever command you wish to run.....egs:
%systemroot%\system32\msconfig.exe
C:\windows\system32\msconfig.exe

Edited by gerbil: n/a

0

gerbil thanks for the response
but i didnt fully understand your reply
could you tell me what to do step by step
i cant open any browser..no program will open except CCleaner
and like i said i cant see the start button to run cmd

0

ok so i got access to TM and i went to file...run new task
i entered msconfig which poppped up without a problem but i was not able to launch system restore from there

so i typed it what you had posted in the above post
and when i do i get the following msg:

system restore is not able to protect your computer. please restart your computer, and then run system restore again

0

Oh, and in case Ctrl-alt-del does not work on your sys to start TM, Ctrl-shift-esc always will.
Ah, fine... with msconfig open try what Caper suggested above.
Also from that msg it is possible that System Restore is turned off. Run: services.msc and scroll to System Restore. Right click and check "properties". By the way, if you enable it, it is only necessary on the OS partition. But I'm afraid if it is off then you will not have restore points.
Can you start that tuneup pgm via New task?:
%programfiles%\"tuneup utilities 2009"\tuneup.exe ... or whatever the path is.. I'm just guessing here. But if you can, there is an Undo option.
Another one: %systemroot%\system32\cmd.exe ... or just cmd in TM. You can use dir, cd etc in cmd window to track down that exe, and start it from there. Perhaps it will run with the damage you have...

Edited by gerbil: n/a

0

ok so i tried what casper said
im able to locate the file that has to be restored (wsock32.dll)
however when i try to go to browse from and and locate the XP cd
im able to open the folder i386 but i dont see the wsock32.dll file there from the expand view
but when i access the XP cd through my computer im able to find the wsock32.dll file in the i386 folder

now what?

0

so i tried to access system restore through services.msc
but when i right click for properties..nothing happens

now what do i do?

0

ok so i have managed to fix the wsock32.dll error everytime i tried to open any of the programs installed on my computer
i did this by using the windows XP cd and running recovery console from boot up
and over wrote the file wsock32.dll from the cd to the computer

however the other issues still persist

i still cant see my taskbar (no start button)
once i type my password at startup and log in it takes several minutes (this was not the case prior to the issue)
i cant move folders or files from one place to another
still cant access system restore through task manager

0

no when i type explorer.exe
my document folder opens up

0

Well, that is a start.... it is certainly part of explorer that is working. But there are some grave registry problems. Okay. Lets check for system file problems first. Into TM > Run again, and enter this:
sfc /scannow
-you will need your installation cd.
Then [or you can do this first], run this in TM:
%systemroot%\system32\cmd.exe ... or just cmd will do in TM. In the cmd window enter:
dir %systemroot%\system32\config > C:\config.txt ...post that file, config.txt.
And then do this in cmd window:
You can then use dir, cd etc to find the exe in Program Files\Tuneup Utilities, and start that program from cmd. The cmd you should use would be something like:
c:\Program Files\Tuneup Utilities 2009\tuneup.exe -you will have to track down the exact path with dir.
If the pgm starts, there is an Undo or Recover button at top right. Use it for a total reversion of all actions you took.

0

i can the sfc \scannnow before

i dont really understand what u mean by post config.txt
i can manage to type dir %systemroot%\system32\config in CMD
and i see a list after that...but what do i do next?

regarding locating the tuneup.exe
i cant find it in the tune up utilities 2010 folder

but i did manage to do something
i opened the folder and clicked on repair wizard for tune up utilities
it asked me select what issues u want corrected and i clicked on a few
and now i can see my taskbar...i guess thats a start

now should i uninstall the program?

0

"i dont really understand what u mean by post config.txt
i can manage to type dir %systemroot%\system32\config in CMD
and i see a list after that...but what do i do next?"
That's not quite what I expected... you should have typed the full line to create file, C:\config.txt:
dir %systemroot%\system32\config > C:\config.txt
You could have then just posted that file via Advanced Editor below.
But the way you did it, you can in a cmd window rclick in the top border, go Edit, Select all, then again but Copy. And paste into notepad.
I wanted the info to see if you had a set of hive backups in the config folder, eg SAM.BAK, security.bak etc for all 5 hives, and if they were of useful dates... ie, not too old but before you did the "tuneup".
So.... check that your sys is now as you expect it to be.... I'd reverse ALL the changes that TU made. And toss it. Look, I just plain do NOT believe in registry cleaners, optimisers etc unless you EXAMINE each and every entry they propose deleting, and KNOW what they represent. But they remove so LITTLE in the way of nuisance/extraneous/useless entries that they are a waste of time. Your reg hives are huge, the cleaners boast of removing what seems like a lot, but is mainly stuff that would be cycled out normally, anyway.
System optimisation? Yes.. there are settings you can change to increase file handling speed... and if you are a gamer they are useful, or for high end processing like photoshop.. if you use it full on. For most folks, defaults do just fine.
Good luck, there.
And turn on Sys Restore for your OS drive. And get ERUNT. Set it so as to make the one week backups of your registry.

Edited by gerbil: n/a

0

ok nothing happens when i type
dir %systemroot%\system32\config > C:\config.txt

and when i try to copy the dir into notepad...it gets saved on the desktop
but then i cant move it to a folder or a USB
i cant copy it either

0

On screen, nothing much does happen, but config.txt is then on C: drive root. Here is a little batch file, does pretty much the same thing:
Copy the text in the box to a notepad [format/wordwrap unchecked] and save as showme.bat to your desktop; dclick it to run, then post the file config.txt

dir %systemroot%\system32\config > C:\config.txt
start c:\config.txt
pause

If you cannot get that to work then just run this in cmd: dir %systemroot%\system32\config
..and write out this info; post it here: I would like to see the creation/modified dates of these files. Most likely they are the same for all, so just give them once and say.
SAM
SAM.BAK
security
security.bak
software
software.bak
system
system.bak
default
default.bak

Edited by gerbil: n/a

0

Or , to cut things short, you could use the Recovery Console in system32\config to rename system to system.bad, and then rename system.bak to system. And try booting.
system.bak may be system.sav.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.