0

I recently almost dropped my laptop (which was working fine till that point). When I restarted my laptop, it wouldn't start. It would go start, and blank out after the boot screen and this would basically form an infinite loop. I put in the installation CD, and went for windows recovery and went straight for FixMBR (don't know why). After this when I restarted, I got the windows startup screen and the BSOD after that. I put the installation CD again and went into the recovery console, and did a fixboot that did not work either. I restarted and went into the recovery console again and tried to read the directory using DIR, and it did not read.

So I did a chkdsk /p and that fixed it and it seemed to read stuff fine

I rebooted and got an error that the ntsokrnl.dll was missing, which i installed using the recovery console.

I rebooted after that, and then I got the Windows\system32\config\system missing or corrupt error. I tried the steps given here

But every time i try that, I get n error which says the file is missing, I navigated to the folder and I see system.sav and system.log but no other files. I tried ren system system.bak but i get the same message - file not found.

I really don't want to reinstall and am hoping to fix this installation. Any help would be appreciated. Thanks !!!

2
Contributors
9
Replies
11
Views
7 Years
Discussion Span
Last Post by gerbil
0

"went straight for FixMBR "... this action should not have hurt anything. It just replaces the code section of the MBR with stock Windows code.
" I navigated to the [config] folder and I see system.sav and system.log but no other files." What files are in \repair folder? sam, security, software, system, default?
Was the hdd running [ie lappy ON] when you mis-handled it? I don't have any idea what sort of g's they can endure before the heads to a dive onto the surface. I'd go back and do a chkdsk /p via Recovery Console. If that gets you access to data, get it off. And then.... run a hdd test utility.
If chkdsk does not help then try the Repair option via Windows Setup.

Edited by gerbil: n/a

0

I don't see the repair option for some reason. I have two installation disks and neither of them have a repair option (I am talking about the repair option you get after you select to install windows, and are selecting the partition to do it in)

Also, my system restore had been turned off. My laptop has been mishandled before, it can take a lot. I am pretty sure the HDD is fine. Its probably the installation which got messed up.

I just checked, there are th llowing files in repair
system
system.bak
software
security
autoexec.nt
config.nt
default
ds_sam
Ds_security
Ds_software
ntuser.dat
secsetup.inf
setup.log

Edited by GrinReaper: n/a

0

"I don't see the repair option for some reason." If you are using M$ disks, then if no option to Repair the installation appears it means that Setup cannot find valid registry hives. Right. If you are getting in to see the \repair folder contents copy over SAM [there is a SAM, right?], Security, Software, System, default to system32\config
DS_SAM... is that a Dell sys?. Then if no SAM you could prob copy over [and rename as you do it] DS_SAM to SAM. It may be a basic Dell recovery option SAM hive... I am guessing here.
Re the drop and catch... I looked at a drive here... it is rated to 75Gs. That would be a drop of the drive itself from a metre or more onto concrete; something with bounce like timber would be higher Gs....

0

Thanks Gerbil for you reply. I copied the files you mentioned to system32\config\. I restarted my PC and then it said that the pci.sys drivers are corrupt
I tried going into th windows installation, it still wouldn't give me the option to repair it( after selecting to install windows)
I then tried enter the recovery console and it asked me for an Admin password. I never had one so I clicked enter and it tells me that the password is invalid. So I now have no access to the recovery console :(
Yes, it is a dell system.

0

Hello, Grin.... no access to RC... yeah, that was always going to happen with an OEM installation , but with no hives showing in your config folder it was worth a try. It's something to do with the way OEMs create/load their OSes into the systems they sell, I do not know the details, but there is something incompatible with their SAM hive and RC. Of course, if sometime after they set their sys up just the way they wanted it people then did a system save they would get new \repair hives which reflected that. Anyway...
What we need to do now is reset the SAM hive passwords for the System Administrator account [the one RC requests], and also your adminstrator account. Easy as.. just get this tool, cd080802.zip from here: http://pogostick.net/~pnh/ntpasswd/
-get the cd iso [zipped], unzip it, burn that image [the.iso] to a cd.
-restart your sys to boot from the cd [hit F8 to get the one-time boot menu];
-when the pgm starts answer the questions, mostly you will type 1 [remember Numlock]
-change both account passwords in the one run [CLEAR them, do NOT set new passwords] by repeating that section
-quit and save [type y when asked if it should write the changes to SAM].
Try the RC with a blank password [Enter].
I know that pgm works with standard installations, it should also work with OEMs like yours.
I cannot figure out why your sys got so blitzed by a fumble, but there ya go.... I don't think astronauts will want you over at NASA.
Note. I just looked at that site.. there is a new version out which offers driver updates.. c100627.zip. I shall have to test it out some time. The one above is fine for my machine [with wireless kb n mouse, lcd].

Edited by gerbil: n/a

0

Thanks! I did what you asked, and replaced pci.sys. Then it asked me to put in NTFS.sys which I did multiple times. No matter how many times I replaced it, it keeps telling me that the ntfs.sys file is missing or corrupt. I tired chkdsk /r and I tried deleting NTfs.sys. Nothing helps :(

0

Oh dear... there are a lot of files in system32 for the sys to be unhappy with.... one at a time...:)
Anyway.... use RC to first rename ntfs.sys to ntfssys.old, then copy in a new one with:
copy x:\i386\ntfs.sys c:\windows\system32\drivers
I wonder if the file table is damaged? Or if your RAM is faulty [needs reseating]... cos I cannot think why you are getting these file problems.

Edited by gerbil: n/a

0

I already tried that. That didn't work. I even turned it off and waited for thing to cool off. Still didn't work. Renaming didn't work either. I am pretty much at my wit's end and considering a reinstall now :(. Is there a way to get around this one ?

0

Grin, something pretty basic is going wrong here, and it is either the hdd or RAM. chkdsk /r is not reporting errors on the hdd when you rerun it? Then it is well worth doing a RAM test; it takes as long as you want it to. This site, http://www.memtest.org/ has Memtest86+ in bootable form for cd [.iso], flashdrive and floppy. I prefer the floppy version if a drive is available.
There is no way your sys could have suffered that much file corruption without it being software-based [virus...].
Because you can now use the Recovery Console [can get in, and it recognises an installation], and because you have used the \repair hives already, there is really no reason why you should not run a Windows Repair [NOT a OEM Recovery... that would blast your installation back to the stone ages - you'd lose everything]. With a Repair you have to reload all updates, but your data files will remain intact. Some softwares will be unhinged anyway because of the hive reversion.

Edited by gerbil: n/a

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.