0

I have been reading for the last month to try to solve my issues with my new hard drive. I liked the challenge for awhile but I just plain sick of it now so I am asking for your help. The multiple topics I have read and tried are close to my problem but none are exact so maybe someone can fill in the blanks for me.

I bought a new hardrive, a SATA and tried to install XP Pro service pack 3. It would not work because after many attempts at trouble shooting I found that the disc was bad.
So I installed windows 7 ultimate and it installed fine (all ten times) but it seems a lot of my hardware on my computer has issues with the OS and every time I would let windows update the registry got corrupted. It would not allow me to restore, I have done : SFC/SCANNOW,BOOTREC.EXE, REGEDIT.EXE, CHKDSK/F/R I have installed the latest drivers for the motherboard, the motherboard is set for SATA and the motherboard recognizes the harddrive. The list can go on and on, as I said I have read and performed dozens of solutions for problems similar to mine. I could just run windows 7 without any updates and see how it goes but I don't want to spend all the time loading and tweaking my new hardrive and have it crash down the road so I decided to install XP Pro service pack 2 which I know is good, I installed it on a spare IDE I had lying around.
I start the computer, press any key and start from the OS disk, I format the drive that 7 was on(NTSF is the only option it gives me) and it copies all the files fine. When it reboots it goes right to a screen “disc could not be read press ctrl/alt/delete to restart”.
I have tried reinstalling XP, deleting the partition, formatting and end up with the same results. Tried to DBAN the drive but the program doesn’t run through the screen shots it shows on DBAN's sight and the bytes or the drive never change after running it. It says it ran without any critical errors but also lists these errors:
error/ dev/sdc process crashed
error dev/sde process crashed
error dev/sdd process crashed
error dev/sdb process crashed
error dev/sda process crashed
Like I said I don't think DBAN is even running as when I press enter after it boots to the first screen it pretty much ends with the info I just listed. I don't even know if I need to run DBAN.
I have also downloaded EASYBCD but it also has its own issues with a can't find folder or something plus I have no idea what I am doing with the program or how to get it to work. I have hit “R” to repair and rewrote the MBR and ran FIXBOOT and probably a few more solutions I have read but nothing changes. It reboots after installing the XP files to the same error about not being able to read the disc.

The only thing this (newbie?) can be sure of is that the XP Pro service pack 2 disc is good (I am using it now on my spare 20GB HD to try and solve my issue) and the hard drive is also good (as it will run with windows 7 ultimate as long as I don't update)

Mainboard> ASUS P4P800-VM
New SATA hard drive> Hitachi HDS721050CLA362 (500GB)
I wish I had the money to go buy another HD (ide) but I am stuck with what I got and can't pay to have It fixed, trust me I would, I'm tired of playing with it .
Can some one please guide me through this or give me a link with step by steps.....Sorry for the long post but I'm hoping it will make it that much easier to solve
Charlie

6
Contributors
15
Replies
16
Views
6 Years
Discussion Span
Last Post by khakilang
0

It's quite possible a faulty ram stick is causing your problems. Run memtest on your system (google will find it) for atleast 3 passes. If you get any errors at all then you need to replace your ram!

0

It could be that the Intel 865G chipset that is on that board does not like SATA operating at its full speed (300 MB/s). This is not a problem for many motherboards since they can throttle that speed accordingly. It could be causing your strange issues though.
Most SATA HDD's have jumpers on them that you can set to down clock the speed to 150 MB/s, however I don't believe Hitachi does this. If that HDD has jumpers, see what it is those jumpers do when set. If your HDD does not have the jumpers to down clock the speed then I would recommend you flash your BIOS with the latest revision.

Strange that the OS Disc see's the HDD just fine though....

try this command next time you are in recovery console or some other PE w/ cmd shell.


bootsect /nt52 C: /force /mbr


Also...
Load the latest SATA driver during the install of XP. I assume you know how to do that...
If not, then all you do is hit F6 as soon as the setup starts to load SATA drivers manually. (you must be quick on hitting the F6 key, it will prompt you first thing after you "press any key to boot from CD", then it goes to the blue setup screen. HIT F6 NOW!

If none of those options work then maybe your HDD and MOBO just don't like eachother. Or maybe your MOBO is failing. Rik mentioned it being bad RAM, have you checked your RAM yet? The XP no booting issue doesn't seem like RAM to me, however the issue you are having with Windows 7 sounds like it could be RAM.

You never gave details on the issue you were having with Windows 7. You just said that the registry corrupts. How do you know it is a registry issue? (I understand your logic behind that assumption, but is there a BSOD that gives a stop code or anything?

If system restore fails on you try running it in recovery console CMD.
"C:\Windows\system32\restore\rstrui.exe"
(or what I use is RecEnv.exe on a PE disc that I made myself)
That has restored Windows successfully after a restore from safe mode and/or recovery console failed.

Good luck!

0

After loading windows 7 I would download windows updates and it would reboot to the startup repair or whatever it is called. It would do this and try to restore itself a few times before saying it could not repair the problem. Clicking "view details" it shows "start up has tried several times but still cannot determine the cause of the problem", Root cause found, number of root causes = 1. I got the same result everytime. I once ran it for a week before I decided to try installing the windows updates again and I got the same results. It will not restore or boot into anything but the startup repair.

As for my xp problem....

What and where do I get the Sata drivers to load at f6?? I will try the commands right now and let you know

thanks

0

I tried the command bootsect/nt52 c: /force /mbr in the xp repair console.(boot from xp cd and pressed "r") and it said it is not a recognized command.

1

Okay Charlie,

I am quite confident you are in luck, and I have the solution for you...

In my previous post I mentioned the issue most likely being caused by the SATA transfer speeds.
The P4P800-VM is an old mobo and it can only support SATA transfer speeds of 1.5Gb/s (as apposed to 3.0Gb/s)

Most SATA HDD's have jumpers on the drive itself to lower the transfer speed to 1.5Gb/s.
However, most(or all) of the Hitachi HDD's do not have this convenient jumper to lower the transfer speeds for backwards compatibility.

This is where the Hitachi 'Feature Tool' comes in.
The Feature Tool allows you to boot to a utility that lets you to change various settings on your Hitachi HDD like the transfer speeds.

I am VERY confident that this will resolve your issue. Just follow the steps I give you VERY carefully and you should be up and running in no time.

I have attached ZIP files which contains the following:

ftool_215.iso - Bootable CD image that contains the Hitachi Feature Tool
Feature_Tool_User_Guide.pdf - A PDF document that lists the steps to run the Feature Tool
Ftool-ver215.exe - An executable that will make a bootable floppy disk with the Feature Tool. (You can either use the ISO, or this MakeDisk executable to create a bootable disk which contains the Feature Tool itself.) So you only need to use one or the other. I just included both because I didn't know which option will be best for you.(I cannot attach this exe file, even in a ZIP so here is the link to download it yourself: http://www.hitachigst.com/hdd/support/downloads/Ftool-ver215.exe
BIOS UPDATE - I included the latest BIOS update on here just in case, as well as the AFUDOS update utility. (Don't worry about flashing the BIOS until you try the Feature Tool first to see if that resolves the issue)

I am going to assume that you do not have a floppy disk drive in your PC so we are going to use the ISO rather than the floppy disk makedisk exe [Ftool-ver215.exe]

Download and install ISO burning software if you don't already have something.
I personally recommend using ImgBurn. You can download it here: http://www.fdccdn.net/33772/imgburn/SetupImgBurn_2.5.5.0.exe

Now using ImgBurn, create a disc using the ISO I included in the ZIP file. [ftool_215.iso]

Boot to that disc...

Once you are in the Feature Tool you need to goto SATA SETTINGS and set the 'Max transfer speed' to 'Up to 1.5Gb/s'

Just set the 'Spread Spectrum Clocking' to 'DISABLED' <---- Do not enable SSC
(The ONLY setting you want to change is the transfer speed to 1.5Gb/s)

Hit OK.

You should get a message that says the settings were changed successfully and you now must power cycle your machine. (CTRL+ALT+DEL is NOT enough. You must power it down by either holding the power button in, or by the switch in the back)


You are now running your HDD at the support SATA I speed of 1.5Gb/s.
Now see if you can successfully boot into Windows. :)

I am almost positive that will solve the issue you are having. There really is not much more I can think of for you to do. I checked Asus' website and noticed that your motherboard does not require SATA drivers, so forget that earlier suggestion I mentioned.

If for some dumb reason that does not fix your issue then you MUST try flashing your BIOS with the latest revision. You can get the latest BIOS update from support.asus.com. But for your convenience I also included the latest BIOS update as well as the update utility in this ZIP I attached.

If you have never performed a BIOS flash before, or if you need help getting the BIOS update onto a bootable CD just let me know and I will send you another bootable ISO w/ the BIOS update. (That is if you don't have a floppy disk drive)

If you have a floppy disk drive then all you need to do is copy the ROM file that is inside the folder called "Using ASUS EZ FLASH" to a blank floppy disk.

Put the floppy in the drive and power the machine on.
As soon as you see the BIOS splash screen during the POST (Power On Self Test), hit ALT+F2 to enter the ASUS EZ Flash Utility.
This utility should automatically see the ROM file and start flashing the BIOS.

When BIOS flash is complete it should automatically restart your PC and that is it!

I really hope this advice will solve your problem, I know how frustrating this has probably been for you and I did my best to solve it for ya. ALSO.....

about the bootsect command I mentioned in my earlier post.
To use bootsect you actually will need to boot to your Windows 7 OS disc. (Or vista)
once inside THAT recovery console you can enter the CMD shell and be sure to enter this command in VERBATIM.

bootsect /nt52 C: /force /mbr

I noticed that the command you replied back to me was incorrect due to incorrect spacing. Not sure if that is what you actually typed, or if that was just a mistake in your last post.

bootsect*SPACE*/nt52*SPACE*C:*SPACE*/force*SPACE*/mbr

Best of luck to you Charlie! If you have any questions at all feel free to PM as well.

Votes + Comments
Impressive work :)
0

Now I feel bad. All the work you did and yours and my excitement and it still doesn't work. Everything went just as you said, it was easy with all the info you gave me. I changed the speed and flashed the bios and this is what comes up on the POST screen:

American Megatrends

Auto-detecting sec master..ATAPI CD-ROM
Auto detecting sec slave... ATAPI CD-ROM
Auto detecting 3rd master.. IDE Hard Disk
Sec Master: Memorex DVD-ROM 16x v2 6w52
ultra DMA Mode-2
sec slave: _NEC DVD_RW ND-1300A 1.05
ultra DMA Mode 2
3rd Master: Hitachi: HD5721050CLA362 JP2OA3EA
ultra DMA Mode-5, S.M.A.R.T. capable and status ok
auto detecting usb mass storage devices..
device #01 : usb2.0
device #02 : usb2.0
device #03 : usb2.0
device #04 : usb2.0
04 usb mass storage devices found and configured

CMOS Checksum Bad
press f1 to run setup
press f2 to load default values and continue

I pressed F2 and this page appeared...

remove disks or other media
press any key to restart (I did, then....)
a disc read error occurred
press CTRL+ALT+DEL to restart


I did all you said in the order you said without anything or any other hard drives connected but the new hitachi sata
I am thinking I will reinstall xp now that I changed the sata speed and pray, I will keep you posted and thankyou

0

Good idea, I hope it works after the reload of Windows. Has it always given you that "CMOS checksum bad" error? And does it do that every time you restart? Sounds like your CMOS battery is dead. Or your motherboard is on its way out. If the reload of Windows doesn't work then I really think it may be a lost cause. Especially after seeing that CMOS error. Also, it sounds like you have some removable media plugged in. I know you have probably removed all of your USB thumb drives and/or external hard drives, but one thing some people don't check that CAN cause a boot failure is a PRINTER with removable storage. Let me know what happens! Good luck!!!

0

I made the boot disk and slowed the sata speed down and left the other option disabled. I then reloaded xp pro and still got the disk read error.
I then changed the bios IDE configuration from enhanced to compatible, no change I also changed IDE configuration from sata to pata-sata (native), no change. I even reinstalled xp with every change I made, also trying BOOTCFG and FIXMBR. I also flashed the motherboard with a floppy of the latest version.

Maybe I would be better off trying to install windows 7 again since it works on the sata, until I do the updates. I spent weeks trying to fix that too. I wish I could take this Sata hard drive back.

I usually don't see the POST screen so I don't know about the CMOS error. I'll keep an eye out. I don't know why the POST screen stayed on that time for me to write all that down. It usually flashes so fast I can't read it.

The only usb plugged in was the wireless keyboard/mouse.

Anymore ideas???

0

auto detecting usb mass storage devices..
device #01 : usb2.0
device #02 : usb2.0
device #03 : usb2.0
device #04 : usb2.0
04 usb mass storage devices found and configured

Is that a card reader?
is it included in the boot order? (try to disable it, or move it below hdd)

Try to reset the bios / load bios default configuration (re-config the sata)

Try to remove cables to any non essential drives/devices during OS install, and plug them in one at a time later, after it installs properly (install with only 1 hdd, and 1 dvd drive attached).

0

I don't know what the "card reader is" it is the screen that comes up while the motherboard is loading? don't know how to describe it. when I boot the ASUS screen comes on I can press delete to enter setup or tab to view that screen as it loads. The POST screen?
I have reset the bios and tried every IDE configuration. I have nothing else plugged in but the dvd and the sata hard drive when I try to load XP. The funny thing is I can install windows 7 on this hard drive with no issues until I do windows updates then 7 gets corrupted and can't repair itself. So I know the drive works, I Just can't get xp to work on it.

0

The card reader is a piece of hardware that is usually installed in a 3.5" floppy bay that is used to plug in SD cards n' such. If you have this then it would be a good idea to disconnect it from the motherboard just in case. It should just plug into one of the USB adapters that is on the motherboard. Also, the POST screen cap you submitted showed this:

"device #01 : usb2.0
device #02 : usb2.0
device #03 : usb2.0
device #04 : usb2.0
04 usb mass storage devices found and configured"

It sounds to me like you have SOME kind of mass storage device plugged in. Whether it be an SD card, thumb drive, external hdd, or whatever.

Also with your Windows 7 issue that you are having can you tell me what BSOD error you are getting, if any. (Blue Screen of Death)

You will have to disable "automatic restart on system failure" to actually see the BSOD error. To do this start hitting F5 or F8, or whatever you usually press to go into Safe Mode. You will see the option to "disable automatic restart on system failure", and now you should be able to see whatever BSOD you are getting. If so, read me all of the technical info it gives you. e.g. IRQL_Not_Less_Or_Equal 0x0000007E ..... or something.

0

If you wish to install XP, there will have been a cd supplied with your motherboard. One of the things on the cd will be a sata driver. In order to get XP on a sata you need to press F5 during the install process when it says about installing a 3rd party storage driver. You then need to insert the cd that came with your motherboard and let it install the sata driver.
When XP was first created, there was no such thing as a sata hard drive, hence XP doesn't have native drivers for sata. The only exception is if you have one of the very last of the XP install disks that did have sata drivers on it, but, because of the problem you are having with XP, you obviously don't.

0

A few other things I thought of.... we are getting desperate here, I am surprised that you haven't given up yet. ;)

It seems like I have fixed a similar issue before by doing a Windows Repair install. Sounds silly, but I am curious if it will even give you the option, given the circumstances.

Boot to XP disc and then hit Enter or whatever as if you were installing XP. The next screen should give you the option to hit 'R' to repair. (Not the same as the previous screen where you hit 'R' to enter Recovery Console.

Worth a shot I guess..

Also maybe swapping your SATA cable could resolve the issue.

Also maybe checking your CMOS battery. It sounds strange, but I always just use my tongue to test the battery.

Disable your floppy in BIOS and also make sure your your boot order goes as follows:

Optical Drive
HDD

Good luck to ya :)

0

when you install xp in a sata HDD, make sure you change IDE mode, go to bios change the connection type, First is ACHI OR SATA OR IDE mode select IDE mode for XP user, after you change to IDE mode save it by pressing F10,, continue formating... hope it works....

Edited by benmar: n/a

0

I think it could be your SATA cable. Have you try changing that? If not get another SATA hard disk to try out if you can.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.