0

I have a 320GB SATA drive that I was using as an external drive when, rather suddenly, the drive stopped functioning. Windows XP (which is what I was running on my old PC) didn't even recognize that I'd attached the drive. Well, I held onto the drive (it was actually under warrenty, but I couldn't get anyone to drop it in the mail for me) and not long ago someone suggested I try a program called MiniTool Power Data Recovery to see if maybe that would help with the drive. Well, I can't get it to recover any data, but unlike Windows 7 (which is what I'm running now) which still doesn't see the drive, in this program the drive IS visible but it won't recover any data (there's a 1GB limit). Now, at this point I'm not as interested in recovereing the data as I once was - sure I wouldn't turn down getting it back, but I'm more interested in seeing if I can get the drive working again.

Is there any way at all to do this, or am I holding onto this drive for no reason?

9
Contributors
25
Replies
130
Views
3 Years
Discussion Span
Last Post by RobertHDD
0

Try this (assuming your on windows):

Open up "Computer Management", and click on "Disk Management" on the left pane. Do you see your external there?

If you do see it, then right click on itm click on "Change Letter and path..." and go ahead and give it a letter to see if it works.

If it doesn't work, then you still have a few options. If you want to recover files off of it, there are plenty of file recovery programs out there.

If you want to format the disk, right click on the disk in Disk Management, and click "Format...".

0

Yes, it does actually show up in the Disk Management tool, but it gets a little wonky here.

The drive is listed as Disk 3, there's a little red down arrow icon on the drive icon, under that it says Unknown, 298.09 GB, Not Initialized and in the space that shows the drive's partition(s) it says 298.09 GB, Unallocated.

When I right click on the drive, the menu that comes up only has the options for Offline, Properties, and Help available (Initalize Disk is greyed out at the top). When I select the "Offline" option, I get a pop-up that reads: Data error (cyclic redundancy check). According to the properties, the device is working properly (???).

Edited by mcortino: typo correction

0

Unfortunately, SpinRite is a pricey investment and one I cannot afford and I don't even know it would help any (and as far as I can see there's no demo of the software). Of the 5 on the list Hiroshe shared, there's only one that can even see the drive.

0

If Windows Disk Management can see the disk then TestDisk should cope with it. Not Initialised shows beacause the LDM cannot see a partition table. TestDisk in its deep search will ignore the partition table and hunt for the boot sectors of each partition, thereby establishing partition boundaries. If you have in the past moved or erased partitions then TD might find these via their bootsectors if they have not been overwritten - a bit of confusion, but checking the data table presented should sort out real from unused.
There is a backup bootsector in the last sector of a partition. Records in the bootsector point to the MFT and the MFT mirror. Pretty much, for each partition you need a valid bootsector (either) and a valid MFT (either). Without these, file recovery is difficult.
Formatting writes a new partition table and NTFS system files to the disk, not a problem in your case cos it is busted already.

0

Unfortunatly, I mostly work with linux. If you still can't get it to work, a stronger handed approch might be to install ubuntu onto a USB stick, and use GParted to try to erase the disk (BE CAREFUL). I trust that more then I would some disk utility in Windows. It's a bit more complicated to pull off I'll admit though.

0

You can quick recover all data from bad drive through third party data recovery software.

Edited by JorgeM: Please no spam/advertising. Future occurrences will result in possible infractions.

0

@gerbil Okay, TestDisk does see the drive, started a analysis of the drive just after I got your message and after almost 2 days it's only at 6% complete.

@Hiroshe I've used Linux in the past to try and get data off this drive but it wouldn't see it, just like Windows. As I'm not overly familiar with Linux though, I don't know if there's some trick that maybe I missed (like in Windows, the main system doens't display the drive but the Disk Manager does still show the drive). I am more then willing to try again, just have to recreate the flashdrive.

@chemline.dorno While it is cheaper than SpinRite, it is still beyond my means.

0

Well, it's clear that the volume is currupted. You won't see it mounted. But, you can use GParted in Ubuntu to format it even if it doesn't appear to be mounted (which will erase everything).

If that doesn't work, then it's almost definatly physically broken.

If you really want to go this far, then in linux open the device file (usually located in /dev/ somewhere) up in bless. Try to write a few bytes directly to the disk, and save. Open the disk back up and see if the changes are still there. This is essentially the most direct and low level way possible to see if you can read and write to that disk.

0

@Hiroshe This might be a dumb question, but is GParted something that installs with Ubuntu or something I have to download as well? And I'm not worried about loosing the data - I considered it lost a while ago.

0

Him mcortino, thanks for getting back re TestDisk. Something must be badly wrong with your disk... an advanced search with TD on my 250GB drive takes around 15 mins. It's a sector scan, it's hunting for boot sectors. Once it has those accepted it can locate the MFTs, and then files.
Minitools have Partition Wizard; I use it for disk manipulation, and it comes with a partition recovery service. Free. Vsn 8 is about a 20GB download.

0

@gerbil Yeah, that's how it's shaping up. I have a MTPW scan running, but it's going to take a bit to complete so I don't have anything to report just yet.

@sanbafuny I have MTPD but it requires me to purchase the full tool before it will let me do anything with it.

@Hiroshe Okay, I tried using GParted, but every time I get Libparted Bug Found!

Input/output error during read on /dev/sdb

If I click Retry it just gives me the same error.

0

@Hiroshe That's what I was afraid of. As it stands right now, it's STILL trying to run the same scan as when I made my last post - and it's not even showing as 1% done.

0

After 9 hours of trying to scan the drive and not even reaching 1% completion, I canceled it. I want to thank everyone for their advice and attempts at helping me get this drive running again, but it's pretty clear that is not going to happen so I'm going to mark this solved (might not be the solution I was hoping for but it is a solution :D)

Edited by mcortino: trying to mark thread solved

0

Once you're mentally committed to the drive's death, there is a cracker rare earth magnet in the "motor" section of the read arm. Put it on your fridge door and you will need a knife blade to lever it off.

0

Is it possible to recover a "bad drive"?

The answer largely depends on the type of damage. If the problem is due to a faulty circuit board, recovering data may simply be a matter of finding a matching replacement. Damaged heads on the other hand can lead to physical damage to the surface of disk platters, and when that occurs some data is irrevocably lost.

Now, at this point I'm not as interested in recovering the data...
but I'm more interested in seeing if I can get the drive working again.

Unless the drive could be repaired without needing to open it up, I would recommend not using it again. Damaged drives do not become more reliable with time.

Edited by AffineMesh

0

I once have a bad drive and have tried all the possible way no luck using software. The best part is to take it to the shop and let people do it with machine.

Edited by bophana1: correct software

0

Was the shop successful? Attempting to recover data from a damaged drive can actually exacerbate the situation. Where recovery is of critical importance I think the safest course of action would be to power down the drive. Find a reputable data recovery expert to handle the task. Local computer shops rarely have the expertise, I'd be wary of letting them 'have a go', but they may know of someone who is an expert in the field.

Edited by AffineMesh

0

But it can also indicate that the drive stopped functioning I think EASEUS will do the job but if i doesnt then its a failing HDD

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.