0

Well call me crazy, but I'm trying to install Windows 98 on an old XP desktop. The problem comes when I try to boot to the Cd-ROM, after hitting F8 and entering the boot menu and choosing "Cd-ROM" it opens a second menu that promps me to choose the boot divice, the only problem is it won't let me. the header of the second menu just states "Windows 98", and I can't use the up/down arrows, num-pad nor page up/down. after 10 seconds the said menu times-out and the machine defaults to the HDD (loaded with Win XP). I'm kinda stuck and any clues or help would be great.

2
Contributors
5
Replies
31
Views
3 Years
Discussion Span
Last Post by <\Jericho>
0

First off, I feel like your going into the Advanced Startup options in Windows XP instead of the bios boot screen.

First just try to boot from the cd directly (by going to your bios with F1 F2 F10 F12 Esc Del, one of those usually works), and choosing the cd as your default boot device.

If I recall correctly, I had a dos 6.22 'rescue' floppy disk that was created from the format options in windows 98 (you might be able to find a copy of it online, or use the one with windows xp perhaps). I first went into the bios setup, and made sure that it tries to boot from the floppy first. I restarted with the floppy and the cd in. Next within dos, I changed drives to the cd drive, and I typed 'setup' to start the installation.

0

Well I tried what you said and it seems that in any BIOS related menu the keyboard wont work. I could try a deferent keyboard. It may just be somthing crazy with the driver for the wireless keyboard I'm using with the machine now and I have a corded keyboard to try with it so that's what i'm gonna do next. if you have any other thoughts on the keyboard angle that would be great. THX

0

also, I looked at the first screen that you think is the advanced startup and the top header says "select first boot divice" dont knwo if thats any help...

0

Oh, yeah. Umm, the keyboard is kind of a funny thing. Make sure that the keyboard isn't connected through usb. The the old fassioned (PS/2) port instead.

It's kind of a funny story. When IBM started creating computers with more then 1MB, they wanted to make sure that it was still compatible with programs that rely on wrapping around. They thought it would be a smart idea to use the keyboard controller to do that. So, in order for you to access more then 1MB of memory, you need to use a keyboard inturrupt. It's kind of silly. It get's even weirder, because some computers come with the >1MB already enabled, so checking involved using the wraparound twice (atleast that's how i did it). This is OT though, so I'll stop.

Hmm, if it said first boot device, then it might not be the advanced startup. yeah, if you can, try to boot from a dos rescue floppy if you still have one kicking around.

Edited by Hiroshe

0

Well that may just be the issue. it IS connected by USB. Not gotton a chance to try the other keyboard yet, but I'll let you know what happens.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.