Nat-PT 0 Newbie Poster

I am trying to get an IPv6 network communicate with an IPv4 problem but have been stuck on it for weeks to no avail. I wonder if anyone is kind enough to take a look at my running configs from both routers and see if they could lead me in the right direction. Im using Packet Tracer so my debug commands are limited due to IPv6 not been fully supported yet by Packet Tracer

Topology

http://i56.tinypic.com/2mn1y0k.jpg

Galway Router:

Galway#sh run
Building configuration...

Current configuration : 622 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Galway
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.10.1 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.1.0 0.0.0.15
network 192.168.10.0 0.0.0.3
no auto-summary
!
ip classless
!
line con 0
line vty 0 4
login
!
end

Castlebar Router:

Castlebar#sh run
Building configuration...

Current configuration : 1005 bytes
!
version 12.4
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Castlebar
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001:3:3:3::1/64
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.10.2 255.255.255.252
ipv6 nat prefix 2001::/96 v4-mapped 
ipv6 nat
clock rate 128000
!
interface Vlan1
no ip address
shutdown
!
router eigrp 1
network 192.168.10.0 0.0.0.3
no auto-summary
!
ip classless
!
ipv6 nat v4v6 source 192.168.10.1 2001::C0A8:A01
ipv6 nat v4v6 source 192.168.1.14 2001::C0A8:10E
ipv6 nat v4v6 source 192.168.1.1 2001::C0A8:101
ipv6 nat v4v6 source 192.168.1.2 2001::C0A8:102
ipv6 nat v4v6 source 192.168.10.2 2001::C0A8:A02
ipv6 nat v6v4 source 2001:3:3:3::2 192.168.1.3
ipv6 nat v6v4 source 2001:3:3:3::1 192.168.1.4
!
line con 0
line vty 0 4
login
!
end

Translations

Castlebar#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---                     
---   192.168.1.14             2001::C0A8:10E         

---   ---                      ---                     
---   192.168.1.1              2001::C0A8:101         

---   ---                      ---                     
---   192.168.1.2              2001::C0A8:102         

---   ---                      ---                     
---   192.168.10.1             2001::C0A8:A01         

---   ---                      ---                     
---   192.168.10.2             2001::C0A8:A02         

---   192.168.1.3              2001:3:3:3::2           
---   ---                      ---                     

---   192.168.1.4              2001:3:3:3::1           
---   ---                      ---