0

Hello to all from a newbie to this forum.

I have read many of the posts here and could not find a solution for this frustrating problem:
I can no longer connect to the internet from my desktop running win2k. I can send and receive email and access FTP servers, but can’t get anywhere from inside a browser. I have tried IE6, FF, Opera, NS, Mozilla. It does not matter whether I type domain name or ip address.

I have a small network with a winxp machine and it can connect to internet with no problem.
Here are the network details:
1 win2k pc
1 winxp pc
1 mac G4
smc barricade four port router
sprint adsl broadband modem

On the win2k machine I have tried the following:
uninstalled nic and installed known good one
replaced cat5 cable with known good one
uninstalled/reinstalled tcp/ip
run fixwinsock

Connection is configured to obtain DNS automatically.
Here is my ipconfig result:
Host Name: my computer
primary DNS suffix:
Node type: Broadcast
IP Routing enabled: no
WINS Proxy enabled: no
Ethernet adapter local area connection 2:
Connection specific DNS suffix:
Description: Realtek TRL8139(A) PCI fast ethernet
Adapter
Phisical Address: 00-20-ED-6F-F4-19
DHCP ENABLED: yes
Autoconfig enabled: yes
IP address: 192.168.3.109
Subnet mask: 255.255.255.0
Default Gateway: 192.168.3.1
DHCP Servers: 192.168.2.1
192.168.3.1
Lease Obtained : tuesday march 28. 2006
Expires : tuesday april 04, 2006

I can ping either IP addresses or DNS addresses.
I cannot ping the win2k computer from mac or winxp pc

2
Contributors
4
Replies
6
Views
11 Years
Discussion Span
Last Post by antioed
0

Click Start-->Run and in the "Open" prompt type cmd and click "OK".

From the command prompt use telnet to diagnose a port issue:

Command: telnet <ip> <port>

Example: telnet 123.123.123.123 80

First try your router's IP...you know you have connectivity on that port if you get a blank screen with a cursor flashing...if you get a "could not connect" then a firewall or network configuration is blocking port 80 (http) traffic thus causing your browser sessions to fail. By telnetting a server on port 80 you are mimicing how your browser taps into a webserver to display pages. IF you cannot do this then there is a misconfigured firewall or network rule somewhere between your hosts and the Internet. First you would check the router for a proxy address or "http restrictions" and disable them if present. If there's nothing in the router then you should try bypassing the router and plugging one of the computers directly into the DSL. If you can hit web pages when directly in then you know it's the router. IF you still cannot hit pages then double check to make sure there aren't any firewalls running on the computer. If you are certain there are no firewalls and you still can't hit pages even when directly attached to the DSL then there is a chance the provider somehow provisioned your DSL to have port 80 traffic blocked. I have worked for very large ISPs in the past I have seen it happen where a specific port is blocked for a small number of IPs. This is a rare configuration error - doesn't happen very often. Some ISPs will block certain ports if they see viral traffic from your hosts/network...you may want to check with the ISP to be sure this isn't your problem. Another thing to ask if if they require you to use a proxy or if they are running transparent proxies...they usually won't want to tell you this. Either way you could check for a "NAT" setting in that SMC and enable it as this may fix a problem with a transparent proxy. I really don't think that's the problem but I've seen weirder things. Good luck!

0

Thanks antioed. I tried the telnet to the router and the modem and could not connect. I tried it from my XP machine and it worked so I think the problem is in the win2k pc. I will double check the firewall situation and get back to you. Is there a test to know if a port is being blocked by a firewall?

0

Problem solved!
I did a registry restore from an earlier winsockfix, which did not help, so I reapplied the fix and it worked. Seems it must have been something corrupt in the "socks".

Thanks for the help!!

Great forum! :cheesy:

0

Interesting...I would have figured that would be reset when you reinstalled the IP stack. Glad to hear you got it working!

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.