0

I would be really grateful if anyone could help me. I know almost nothing about computers and I think this problem will make me mad soon. :eek:
I have two computers at home, one of them having win xp (it's a notebook if that matters), and the other one win 98. While working separately, Internet was accessible on both of them (constant broadband connection, cable modem). BUT: when I installed (if that's the right word) a switching hub (5-port) and connected them, sg strange happened: 1 the computers see each other; 2 the notebook with xp has Internet; 3 the win 98 computer cannot reach Internet.
I cannot understand this. There's no problem with the Internet access (as it's ok on the notebook), no problem with the switching hub (as the computers see each other, although it takes some minutes for win98 to find my notebook), so WHAT'S WRONG? I suspect that there may be a special setting needed in win98 to reach the internet, but I've tried a huge number of possibilities in vain. If you have any idea about how to solve this, I would really appreciate it. Thanx a lot! :confused:

7
Contributors
11
Replies
13
Views
12 Years
Discussion Span
Last Post by chrisbliss18
0

the best thing i can think of at the moment is to create a network setup disk on your xp computer (requires one floppy)
to do this on ur note book go to:
Start>
Control panel>
in network and internet settings and click network settings or just click the icon if its just catagory view>
follow instructions and click the options listed as apply, like this computer connects thr a residental gateway>

once reached the end of the setup, u will have the option to create a
network setup disk - create one for yourself

this will enable you to do the same on other computers not running xp, doing this on ur win 98 comp might help u out alot,
but it could possibly b another reason 4 the loss of internet, but give that a try and let me kno how it goes, hope that helps.

Danniboy. ;)

0

...the best thing i can think of at the moment is to create a network setup disk on your xp computer...

Danniboy. ;)

footprint the problem first

1

...I have two computers at home...I installed...a switching hub ...

a hub will work for you only if your ISP is setup to assign 2 or more ip addresses for your account/cable modem

most isp co's only assign 1 ip address for access - this is something that you're going to need to find out for sure before we can help you find the most economical, and efficient, solution to your connection issue

my guess is that your isp only assigns 1 ip address per account or cable modem

if you have a hub it won't work, you'll need to get a (low cost) router
if you have a "smart" hub it won't work, you'll need to get a (low cost) router
if you have a multi-port switch then it needs to be setup properly, and it still may not work for you

find out from your isp if they assign just the one ip address or do they offer multiple ip addresses per account/cable modem, and how they are assigned (either dynamic/via DHCP or specified/static).

and let us know what piece of equipment you actually have (manufacturer, model, designation - whatever is written on it, or indicated on the instructions/manual

Votes + Comments
Good advice. Like your sig too. -- dlh
0

a hub will work for you only if your ISP is setup to assign 2 or more ip addresses for your account/cable modem... my guess is that your isp only assigns 1 ip address per account or cable modem

That's almost certainly the case, and a broadband router (from Linksys, Netgear, D-Link, etc.) is the most painless solution.

With a broadband (that is, "always on") connection, you should be using a router anyway, even if you only have 1 PC. Due to their built-in security/firewalling features, broadband routers provide an added level of protection against malicious attacks from outsiders.

0

First of all: thanks for everybody who tried to help!
To make it clear: I have a multi-port switch which is set up properly, and works. The two computers "access" each other, i can send things from my comp to the other one and vica versa, so my home network is OK.
What's more: when the comps are working separately, Internet access is no problem on either of them. The problem is that we cannot use the Net at the same time.
I've called my isp, they told me everything should be all right, as they don't work w/ fixed ip addresses, but i get a different one each time I log on to the Internet, so the number of ip addresses required for one account does not really matter (the max number is 2 by co regulations anyway).
I also asked some friends about the issue, and found two people having the same isp and using the net on more comps (one of them having a router to use 3 PCs /-different type of account/, the other one having a switch to use 2 PCs /-absolutely the same situation, w/o any trouble/). Unfortunately, neither of them uses win98 on neither of their comps, so -although they came & tried everything - the problem remained.
At the moment i'm working on the "creating a network setup disk" project, I'll tell you if that way i succeed.

Tündi

0

Sounds like you are doing alright, can you do this for us:

On 98, start run, "winipcfg" and click OK. Write down all these numbers.

On XP, start run, "cmd" and click OK. Type "ipconfig" and press enter. Write down these numbers.

Their IP addresses should match up the first three numbers and have the last number different on each machine. They should both have the same default gateway. Are both of these true?

0

Interesting enough, I have the same problem with my WIN98 PC. I'm using a router. Although the WIN98 PC used to be able to see the web via the current network but can not now. In fact, the problem seems to be with IE. It can not even see the router. The gateway address shown by both the XP and the WIN98 machines are the same and the two PCs have different IPs assigned to them.

This problem seemed to develop over time; the WIN98 machine took longer and longer to reach web sites and often froze in the attempt. The problem showed on IE and Netscape. Now, Netscape doesn't even seem to want to load.

Strange thing though, I have a weather program running at startup on the 98 machine and it obtains the correct weather info. However, one of the windows that it normally presents simply shows busy attempting to get info. It seems like there is a port or something that is just used by browsers that is not enabled.

I've shut down the WIN98 McAfee firewall and virus check thinking they may have been causing a problem. Of course, the problem may be something that got by them that is throttling the 98 PC!

Perhaps I'll try the suggestion of creating a network disk with the XP.

0

Well I Created a Network Disk and ran it on the 98 machine and still the problem remains.

Incidentally, I can successfully ping the router and the XP machine on the network from the 98 machine. However, the Ping window hangs up if I attempt to ping Yahoo.com, for example.

0

Hi all!

The problem seems to be solved. I have installed a router to connect the two computers to the net instead of the switch i used previously. The good news is that Net is available on both computers at the same time now. The bad news is that DC++ can only be used on the other computer if it is directly connected to the Net (without using the router) in which case of course Net is not available on my notebook. I suppose this must only be a question of configuration however, so I think I'll start a new topic on this issue.

Thanks for all of you who have tried to help, really.

Tündi

0

Tundi - I'm glad for you that your problem is solved. However, I've always used a router and my problem remains.

0

Tundi - I'm glad for you that your problem is solved. However, I've always used a router and my problem remains.

Considering that your 98 machine can access the internet (since your weather program works just fine), your problem is most likely software related. Have you tried running antivirus scans or antispyware programs?

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.