Good day,
I have been trying to enable dotnet 3.5 on my laptop which is running Windows 10.I have tried the following solutions from the internet with no success:

  1. Enable the feature from control panel
  2. Downloaded the DotNetFx35Client and DotNetFx35.exe installs but they are end up trying to download from the internet and they fail
  3. Using the Microsoft-Dot-Net-Framework-35-Offline-Installer but no joy
  4. Using the DISM tool but get this output
    >>Dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:C:\sources\sxs
    Deployment Image Servicing and Management tool
    Version: 10.0.10240.16384
    Image Version: 10.0.10240.16384
    Enabling feature(s)
    Error: 0x800f081f
    The source files could not be found.
    Use the "Source" option to specify the location of the files that are required to restore the feature. For more information on specifying a source location, see http://go.microsoft.com/fwlink/?LinkId=243077.

    1. Tried to check if these KBs (KB2966826, KB2966827, KB2966828) are not installed and they were not installed

    Can someone please assist me I seem to have exhausted most internet solutions

    Please assist.

Ooh dear I finally got it.

I mounted my OS iso (nb: the OS iso must be the same version as the OS running on the machine) as a virtual disk and i run the DISM utility using the above command and it worked like a charm.....

I was using the wrong OS Disk...

This question has already been answered. Start a new discussion instead.