0

Hi everyone,

I had this problem with phpMyAdmin and successfully fixed it. Then, after some days, I encountered the access problem with the WAMP server. I haven't changed anything yet. Or maybe, I need to set up the environment variables?

The message I'm getting is that

Forbidden

You don't have permission to access / on this server.

I searched for some solutions on the web but I couldn't be bothered to keep searching(REALLY Lame!!). Well, no. I wasted enough time on searching for a solution. You guys are AWESOME and some of you may know what might be causing the problem.


Hear from you, Folks.

3
Contributors
12
Replies
13
Views
5 Years
Discussion Span
Last Post by rotten69
1

The error message is from Apache, it has nothing to do with MySQL. Look in your apache configuration file (httpd.conf) and in the local directory's .htaccess files for access restrictions.

0

The error message is from Apache, it has nothing to do with MySQL. Look in your apache configuration file (httpd.conf) and in the local directory's .htaccess files for access restrictions.

None of those files were touched before I wasn't given access to the local server. I don't know what exactly needs to be changed in the files in order for the server to get working as normal. I also don't want to stuff everthing up by changing directories in the files.

Before I seek help, I changed the lines between <directory> tags where the DenyAllow command is. Then, I had to get them to default settings as it hasn't fixed the problem.

Any help please on how to fix the issue?

Cheers,

0

Did you restart the server after the changes? That would be necessary.
Also, have a look at the apache error log which in standard configuration often contains reasons for access restrictions.

0

@smantscheff... Yeah, I did mate. Hmmm, Where do I find the error log ? Is that on their site or in one of the apache files on my machine?


Cheers,

0

The apache log usually resides in /var/log/apache (on linux) or in apache/logs (on windows) on the machine on which the apache server is installed. What do you mean with "their site"? I don't understand your environment setup.

0

Or it may be an environment set-up problem. Do I need to configure the path and environment variables?

0

I did not mean the OS's ENVIRONMENT but the ecosystem in which you dwell. No, it's not an ENVIRONMENT problem as you get error messages from apache which means that the server is running o.k. But on which machine does it run, which URL do you use, and what do the apache error log has to say about your attempts?

0

I solved the problem. Now, I do have access to the local server by using the IP address. But, I can't access it by using http://localhost

Here is what I have in the httpd.conf


<Directory "c:/wamp/www/">

Options Indexes FollowSymLinks

AllowOverride all


# onlineoffline tag - don't remove
Order Deny,Allow
Deny from all
Allow from (THE IP ADDRESS(numeric value))

</Directory>

Cheers,

0

That is what Apache gives in the access log text file.


::1 - - [19/Jan/2012:21:53:49 +1000] "GET / HTTP/1.1" 403 202
::1 - - [19/Jan/2012:21:58:03 +1000] "GET / HTTP/1.1" 403 202


That is only when I'm trying to access the server using localhost in the URL bar

Edited by rotten69: n/a

0

PROBLEM IS FINALLY SOLVED. Just would like to make this thread useful for others who perhaps have the same or even similar problem to mine.

I could access the local server by using the local IP address. For the server to give me access just by using http://localhost or even more sensible names such as MyName.com or whatever name I want to use.

I opened this file and changed a few things. The file is C:\Windows\System32\drivers\etc\hosts.

I added my local IP address then followed by a name like localhost or rotten69.com or whatever name you'd like to use.

Eventually, you will have something like this: 124.44.00 localhost or 124.44.00 rotten69.com

NOTE: DO NOT ADD # at the beginning of the line.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.