0

I tried to install the devil library but I am getting some
errors. Here are the steps that I am taking to install it :

Let me see if I did this correctly :

Steps :

1) download DevIL 1.7.8 for windows 32 bit
2) extract the info to c:\devil folder
3) open visual studio 2008 tool->options.
4) goto VC++ Directories
5) change the options to show Include Files
6) Add file directory -- C:\devil\Include
7) change the option to show Library Files
8) Add file directory -- c:\devil\Lib
   (note) there is a unicode folder inside of Lib folder
9) Click Ok
10) click alt-F7 for project options
11) goto c++ tab and under Addition Include Directory add C:\devil\Include
   (not sure if thats needed)
12) under c++ tab--code generation--make sure Runtime library is on multi-thread debug dll(/MDd)

13) click ok.

Then on my program add some or all header :
#include<IL/il.h>
#include<IL\ilu.h>
#include<IL\ilut.h>

from this in my functions ilInit() works, but iluInit() causes a linking error, as well as ilutInit().

Am I doing this correctly

Even if I don't use ilu or ilut, I need ilu, and it does not give me an linking error, but when I try to load an image

with ilLoadImage(L"starts.bmp") it return false. Even if I try absolute path like
ilLoadImage("C:...\project\loadimgwithlib\start.bmp") it won't work.

Anyone have it working with visual studio 2008 and with openGL?

2
Contributors
2
Replies
4
Views
8 Years
Discussion Span
Last Post by AlbertPi
0

I tried to install the devil library but I am getting some
errors. Here are the steps that I am taking to install it :

Let me see if I did this correctly :

Steps :

1) download DevIL 1.7.8 for windows 32 bit
2) extract the info to c:\devil folder
3) open visual studio 2008 tool-&gt;options.
4) goto VC++ Directories
5) change the options to show Include Files
6) Add file directory -- C:\devil\Include
7) change the option to show Library Files
8) Add file directory -- c:\devil\Lib
   (note) there is a unicode folder inside of Lib folder
9) Click Ok
10) click alt-F7 for project options
11) goto c++ tab and under Addition Include Directory add C:\devil\Include
   (not sure if thats needed)
12) under c++ tab--code generation--make sure Runtime library is on multi-thread debug dll(/MDd)

13) click ok.

Then on my program add some or all header :
#include<IL/il.h>
#include<IL\ilu.h>
#include<IL\ilut.h>

from this in my functions ilInit() works, but iluInit() causes a linking error, as well as ilutInit().

Am I doing this correctly

Even if I don't use ilu or ilut, I need ilu, and it does not give me an linking error, but when I try to load an image

with ilLoadImage(L"starts.bmp") it return false. Even if I try absolute path like
ilLoadImage("C:...\project\loadimgwithlib\start.bmp") it won't work.

Anyone have it working with visual studio 2008 and with openGL?

try to change From:
#include<IL\ilu.h>
#include<IL\ilut.h>
to:
#include<IL/ilu.h>
#include<IL/ilut.h>

0

try to change From:
#include<IL\ilu.h>
#include<IL\ilut.h>
to:
#include<IL/ilu.h>
#include<IL/ilut.h>

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.