0

Hello,

I need to find out how come my website breaks in IE/9. I've not tested in any other IE, but in IE9 it breaks. It's all over to the left and the Navigation Bar goes horribly wrong. If you don't have IE9, here's an image: http://www.mingul.co.uk/jadonsnapr/AjDUPg.jpg and an image of how it should look: http://www.mingul.co.uk/jadonsnapr/kvP0xw.jpg Notice the difference?

If you could please let me know what's wrong with it, if it means making a stylesheet for IE I've not a clue how to do this. I'm the not the best coder but I have no idea how to fix this. There's a few stylesheets for the website, I'll paste all the code in pastebin links.

header.php: http://pastebin.com/bfvETvdY
index.php: http://pastebin.com/6wavrKus
styles.css: http://pastebin.com/L7H0Nq4x
menu.css: http://pastebin.com/98BjMFcX

Thank you, and any help is much appreciated. I'm sure it's a real obvious error, hopefully I don't even have to make an IE Stylesheet just an "if IE"? Let me know. Thanks.

2
Contributors
2
Replies
3
Views
5 Years
Discussion Span
Last Post by zobadof
1

I beleive what is happending is that you are not including a doctype in your header.php code. The first line should be..

<!DOCTYPE html>

This ensures that IE enable standards mode and renders correctly.

The basic structure for your HTML code should be..

<!DOCTYPE html>
<html lang="en">
<head>
    <meta charset="utf-8" />
    <title>Page Title</title>
    <link href="style.css" rel="stylesheet" />
</head>
<body>
    <!-- Your content -->
</body>
</html>
0

Ah yes, thank you. Forgot to add that. Knew it would be a simple solution.

Thanks again.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.