Hello,

I am creating a website in WordPress.
http://patricia.kwayyinfotech.com/

In Google Chrome browser, on opening any page from my site, the browser loading disappeared and the page white screen. The problem is that user may confused that the site is opening or not as the browser loader is stopped and look like nothing happening to the page. But after 2 or 5 seconds, the page is showing content.

Also this happen randomly. You need to browse the site to see the problem.

I am not sure is this Google Chrome problem or any other issue. So I am asking to you. Is there any code change I need to do to show browser loader?

Here is how I use my site loader:

 //Place this just before the head tag.
 //Load jquery.js file before you load the script below.
  <script type="text/javascript">
        jQuery(window).load(function($){
            jQuery(".loader").fadeOut("slow");
        });
    </script>
  <style type="text/css">
    .loader {
        position: fixed;
        left: 0px;
        top: 0px;
        width: 100%;
        height: 100%;
        z-index: 10001;
        background: #f0f0f0 url('http://sanjayghosh.stellervision.com/wp-content/themes/sanjayghoshmd/images/page-loader.gif') 50% center no-repeat;
    }
    </style>


//Place this after your body tag
<div class="loader"></div>

please, DONT put any dumb loading screens
the extra time wasted to load and display the "loading" image is usually longer than the time taken to load the page if the page is optimised properly, optimise the page and this crap is unneccessary
this thread read me before you ask for review is full of instructions

Good thing he didn't ask for our opinion's about page loader's, else you would have giving him a new one.