0

I have a friend who just bought a Toshiba Satellite A65-S1762 laptop. He can't get most USB devices to load onto the computer. It will recognize the device, but that's as far as it will go. We tried going into device manager to see what the problem was, but it couldn't find anything wrong. We have tried a 160 GB external Maxtor HDD and numerous memory sticks (1 actually worked). The problem still exists after installing the drivers that came with the devices. The USB mouse we plugged in worked. He can't send it back to the factory because we're in Afghanistan and it would take too long so our only recourse is to fix the problem ourselves. Anyone have any suggestions?

-Grant

3
Contributors
4
Replies
5
Views
12 Years
Discussion Span
Last Post by Thong_Ispector
0

Hello,

What OS are you working with? I am wondering if the USB devices on the computer need a driver update. Might even be BIOS related.

I would go to the laptop manufacturer's website, and look there for driver updates.

Christian

0

We're working with Windows XP home edition. The computer's brand new, shouldn't need any updates. I gave my friend a USB PCMCIA card that came with my old Mac and he plugged it in. With that, all the USB devices started working. The computer's USB ports still aren't working, but at least he can use USB. I think it's a hardware problem but we'll check the website anyway. Any more thoughts?

0

Just because a computer is NEW does not mean everything is up to date...

If all else fails, delete the USB drivers and reinstall them...

I dont need a Mac ... I run Linux...

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.