0

My epson stylus TX110 printer doesn't show ink levels anymore. It was fine when I bought it but after my black ink ran out I changed the cartridge and the ink levels won't show anymore. All of the ink levels are gray, gray as in disabled gray. All I did was change the cartridge of the black ink.

The cartridge I bought was not fake it was original. I replaced it with a new once 'coz the cartridge for 73N is not refillable.

How can I check my ink levels?

3
Contributors
3
Replies
7
Views
7 Years
Discussion Span
Last Post by talablink
0

This is what I found

The graphic displays the ink cartridge status when EPSON StatusMonitor was first opened. To update the ink cartridge status, click Update.
Epson cannot guarantee the quality or reliability of non-genuine ink. If non-genuine ink cartridges are installed, the ink cartridge status may not be displayed.
If any of the ink cartridges installed in the printer is broken, incompatible with the printer model, or improperly installed, EPSON StatusMonitor will not display an accurate status of the ink cartridge. Be sure to replace or reinstall any ink cartridge indicated by the EPSON StatusMonitor.

I was hoping that they might say something about resetting it but...

0

I do not know much about printers but yes would like to say that you can use remanufactured inkjet cartridges in your printer without any doubts for your printer. You can also check for the ink levels by resetting them when you change your inkjet cartridges. when you reset them they generally show and it works with these kind of inkjet cartridges.

0

Thanks a lot guys. I tried uninstalling all the drivers in my printer and reinstalled it again and it worked.

This question has already been answered. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.