0

I work in IT Tech support (Hardware & Networking) so have a fair bit of knowledge and experience but this one has really got me stumped.

I got a tower running XP Pro on IDE 0 with DVD RW and on IDE1 I got 2nd data HDD. Both are Maxtor drives. It’s a fairly old machine but serves its purpose until recently.

The problem started when I accidently left my USB flash drive in and forgot when I booted. My legacy USB devices were set as priority in boot sequence so I got message "Operating System not found" since there is no OS on my pen drive. Instantly I realised I had left my USB pen drive in and removed it then rebooted fine that time.

However since then I still get the OS not found please read on as I have tried everything. I now have my legacy USB support turned off and have removed it from the boot sequence. AND no I do not have my USB flash drive still plugged in. I have even removed my PCI USB2 cards and now only use the onboard USB2.

PROBLEM: My BIOS is loosing my hard drives intermittently and I get standard message “Operating System not found” I pretty much think I have tried absolutely everything to fix it. Here is a list of some of the things I have done.

Checked and swapped CMOS battery (twice) but the date and time always remain correct as well as settings it is only the drives that go missing

Checked all mobo and HDD jumpers, swapped out IDE cables numerous times plus a new PSU for good measure
Tried all BIOS settings methodically
Run XP recovery console for following commands:
chkdsk /r
fixboot
fixmbr
bootcfg

I have reinstalled XP both repair and clean install.

I suspected one of the HDD was failing so I ghosted both drives to new drives and run chkdsk on the new ones.

I have run extensive Maxtor HDD diagnostic tools on the drives all say they are fine apart from 1 invalid partition so I ran partition magic and made my primary partition active.

I ran fdisk formatted and repartitioned my boot HDD then installed XP again

My HDDs are set to auto find in BIOS but I do not know the manual settings as they are not written on the drive casing. I would like to manually key in the heads, cylinders, LBA etc rather than leave on auto and I found Maxtor manual for drives but only LBA settings listed and it was a huge tech manual for it

I flashed my BIOS to the newest available (it is an old Phoenix BIOS on a emachines mobo for Hewlett Packard) I want to get hold of previous version and flash it back but none are available anywhere on net they are listed but dead links only currant link is live (I spent many days searching)

Now then its not all doom and gloom but my only saving grace is that, at least, I can get the machine to boot. I have to switch PSU off and unplug power to all drives then boot. When it fails I switch power again, plug all drives back and F1 to BIOS setup then it finds drives I exit saving changes and it boots to XP with both HDD and DVD drives. Next time I boot I get same OS not found error and have to repeat the whole thing again.

Please someone come up with something new I am loosing my hair rapidly!

Edited by decay: n/a

2
Contributors
6
Replies
7
Views
9 Years
Discussion Span
Last Post by decay
0

The only thing you didn't say you did was to short the CMOS where the expected POST configuration is stored. That could explain your first problem. I know you had the CMOS battery out but I only believe in shorting the CMOS as a means of clearing it. Then the BOOT ROM will restore the CMOS to correct configuration and maybe these annoyances will disappear.

Long shot at this stage.

0

Thank you Suspishio any shot is worth a try. I even got a PCI IDE controller card today as I thought my IDE controller may be on its way out. After a long slog getting it working in my BIOS I still get the same problem.

So Shorting the CMOS. Obviously all mobos are different but how would I go about doing this or finding out how to do it? Please note my board is a few years old and there is very limited documentation online.

0

Thank you Suspishio any shot is worth a try. .....So Shorting the CMOS. Obviously all mobos are different but how would I go about doing this or finding out how to do it? Please note my board is a few years old and there is very limited documentation online.

You haven't mentioned your mobo but then you can Google it as well as I.

There are a number of accessible jumpers on the mobo. You can look at any mobo schematic and you'll find them as a guide for you to do likewise on yours.

It's technically known as the Clear CMOS Jumper and might be labelled CLR_CMOS.

1. Turn off the AC supply

2. Use the jumper cap you'll find at pins 2&3 of CLR_CMOS and connect pins 1 & 2

3. Return the jumper to pins 2 & 3

4. Reconnect AC power and boot up

Let us know.

0

Sorry Suspishio I got my wires crossed a bit with your first post. One thing I do know about my board is the jumper settings and I have already used the clear CMOS jumper and forgot to mention it. I have done this several times and is common practice to me as well.

When you said short the CMOS I thought you meant getting a paperclip, tin foil or similar and bridging circuits and really shorting it.

I think I am right in thinking that when you move the clr CMOS jumper and power on that nothing happens to the eye at least (I.e. the PC does not power on). But behind the scenes it clears the CMOS and then when replacing it back to original jumper settings it boots as normal? At least this is what happens when ever I have done it in the past. Please let me know if I am doing something wrong here, because in all the years, on all the systems that I have cleared the CMOS I have never realy noticed any results. But I do this anyway for good measure.

It is as if my Hard drives are all too slow at startup as I hear them kick in (whir) after the POST. I have also noticed my POST is now super fast even if I disable quick POST mode. I am getting to the OS not found message too quick for my liking and only then do I hear the HDD's start. I have tried pressing pause during the POST but no luck. I have never known this message to be this troublesome. Normally 9 out of 10 it is either faulty HD or CMOS battery.

0

Not quite. You disconnect the AC and short the CMOS via pins 1 & 2. The CMOS at that stage is on battery. You don't power on at this time.

You then unshort the CMOS by returning the pins to 2 & 3.

Then you connect the AC and boot to a blank CMOS. BIOS defaults will be used to populate the CMOS according to what the BIOS finds.

You can interrupt the boot in the normal way to set the default boot sequence.

If the above doesn't solve the problem (and prolly removing the CMOS battery that you mentioned should have cleared the CMOS down but I always short it instead), then I would be looking at a hard fault. Like a glitching IDE controller and the USB thing is just a coincidence.

But it has been seen before that a USB stick can "confuse" your CMOS settings which is why I went for that proposal.

0

Thanks again. "You Rock!" I am off to bed now but will try this procedure in the morning. What I was doing was basically the same only I tried to power on in between. It never powered and I did get setup defaults loaded so think it worked all the same.

If it fails again I may try and get my hands on another board and see if this helps which I am guessing 100% will work. Its a useful PC so its a shame to scrap it, but worse I hate being beaten by a dead machine. Its now more of a battle of principle.

This topic has been dead for over six months. Start a new discussion instead.
Have something to contribute to this discussion? Please be thoughtful, detailed and courteous, and be sure to adhere to our posting rules.